<!DOCTYPE html>
<html>
<head>
  <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.csnmidatlantic.com/sites/all/themes/custom/nbcsports/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="tp:EnableExternalController" content="true" />
<link rel="amphtml" href="http://www.csnmidatlantic.com/washington-redskins/need-know-setting-odds-redskins-top-draft-pick-one-last-time?amp" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57.png" rel="apple-touch-icon" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57-precomposed.png" rel="apple-touch-icon-precomposed" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72.png" rel="apple-touch-icon" sizes="72x72" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72-precomposed.png" rel="apple-touch-icon-precomposed" sizes="72x72" />
<meta name="description" content="Need to Know: Who will the Redskins take with their first-round pick? Tandler sets the odds one last time." />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114.png" rel="apple-touch-icon" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114-precomposed.png" rel="apple-touch-icon-precomposed" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120-precomposed.png" rel="apple-touch-icon-precomposed" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144.png" rel="apple-touch-icon" sizes="144x144" />
<meta name="robots" content="follow, index" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144-precomposed.png" rel="apple-touch-icon-precomposed" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152-precomposed.png" rel="apple-touch-icon-precomposed" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180-precomposed.png" rel="apple-touch-icon-precomposed" sizes="180x180" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180" />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.csnmidatlantic.com/sites/csnma/files/2017/04/26/reuben_foster_2_usat.png" />
<link rel="canonical" href="http://www.csnmidatlantic.com/washington-redskins/need-know-setting-odds-redskins-top-draft-pick-one-last-time" />
<link rel="shortlink" href="http://www.csnmidatlantic.com/node/1086991" />
<meta property="og:site_name" content="CSN Mid-Atlantic" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.csnmidatlantic.com/washington-redskins/need-know-setting-odds-redskins-top-draft-pick-one-last-time" />
<meta property="og:title" content="Need to Know: Setting the odds on the Redskins&#039; top draft pick one last time" />
<meta property="og:description" content="Need to Know: Who will the Redskins take with their first-round pick? Tandler sets the odds one last time." />
<meta property="og:updated_time" content="2017-04-27T09:57:14-04:00" />
<meta property="og:image" content="http://www.csnmidatlantic.com/sites/csnma/files/2017/04/26/reuben_foster_2_usat.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="http://www.csnmidatlantic.com/washington-redskins/need-know-setting-odds-redskins-top-draft-pick-one-last-time" />
<meta name="twitter:title" content="Need to Know: Setting the odds on the Redskins&#039; top draft pick one last time" />
<meta name="twitter:description" content="Need to Know: Who will the Redskins take with their first-round pick? Tandler sets the odds one last time." />
<meta name="twitter:image" content="http://www.csnmidatlantic.com/sites/csnma/files/2017/04/26/reuben_foster_2_usat.png" />
<meta property="article:author" content="https://www.facebook.com/TandlerCSN/" />
<meta property="article:published_time" content="2017-04-26T18:56:05-04:00" />
<meta property="article:modified_time" content="2017-04-27T09:57:14-04:00" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
  <meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no">
  <title>Need to Know: Setting the odds on the Redskins' top draft pick one last time | CSN Mid-Atlantic</title>
  <!-- Don't remove this. We are loading base file at first -->
  <style id="base-css">html{font-family:sans-serif;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%}body{margin:0}article,aside,details,figcaption,figure,footer,header,main,nav,section,summary{display:block}audio,canvas,progress,video{display:inline-block;vertical-align:baseline}audio:not([controls]){display:none;height:0}[hidden],template{display:none}a{background:transparent}a:active,a:hover{outline:0}abbr[title]{border-bottom:1px dotted}b,strong{font-weight:bold}dfn{font-style:italic}h1{font-size:2em;margin:0.67em 0}mark{background:#ff0;color:#000}small{font-size:80%}sub,sup{font-size:75%;line-height:0;position:relative;vertical-align:baseline}sup{top:-0.5em}sub{bottom:-0.25em}img{border:0}svg:not(:root){overflow:hidden}figure{margin:1em 40px}hr{box-sizing:content-box;height:0}pre{overflow:auto}code,kbd,pre,samp{font-family:monospace, monospace;font-size:1em}button,input,optgroup,select,textarea{color:inherit;font:inherit;margin:0}button{overflow:visible}button,select{text-transform:none}button,html input[type="button"],input[type="reset"],input[type="submit"]{-webkit-appearance:button;cursor:pointer}button[disabled],html input[disabled]{cursor:default}button::-moz-focus-inner,input::-moz-focus-inner{border:0;padding:0}input{line-height:normal}input[type="checkbox"],input[type="radio"]{box-sizing:border-box;padding:0}input[type="number"]::-webkit-inner-spin-button,input[type="number"]::-webkit-outer-spin-button{height:auto}input[type="search"]{-webkit-appearance:textfield;box-sizing:content-box}input[type="search"]::-webkit-search-cancel-button,input[type="search"]::-webkit-search-decoration{-webkit-appearance:none}fieldset{border:1px solid #c0c0c0;margin:0 2px;padding:0.35em 0.625em 0.75em}legend{border:0;padding:0}textarea{overflow:auto}optgroup{font-weight:bold}table{border-collapse:collapse;border-spacing:0}td,th{padding:0}html{font-family:Arial, Helvetica, sans-serif}a{text-decoration:none}h1,.alpha,h2,.beta,h3,.gamma,h4,.delta,h5,.epsilon,h6,.zeta{font-family:Arial, Helvetica, sans-serif;text-transform:uppercase}h1 a,h1 a:visited,.alpha a,.alpha a:visited,h2 a,h2 a:visited,.beta a,.beta a:visited,h3 a,h3 a:visited,.gamma a,.gamma a:visited,h4 a,h4 a:visited,.delta a,.delta a:visited,h5 a,h5 a:visited,.epsilon a,.epsilon a:visited,h6 a,h6 a:visited,.zeta a,.zeta a:visited{text-decoration:none}h1,.alpha{font-family:"BebasNeue", Arial, Helvetica, sans-serif;font-size:40px;font-size:2.5rem;font-weight:400}h2,.beta{font-size:34px;font-size:2.125rem}h3,.gamma{font-size:21px;font-size:1.312rem}h4,.delta{font-size:18px;font-size:1.125rem}h5,.epsilon{font-size:16px;font-size:1rem}h6,.zeta{font-size:16px;font-size:1rem}p{margin:0 0 1em}blockquote{padding:0 1.5em;font-style:italic}blockquote p{margin:0}q{font-style:italic}mark,.marker{padding:0.1em 0.5em;background:#666;color:#fff;font-size:12px;font-size:0.75rem;text-transform:capitalize}::-webkit-input-placeholder{color:#fff}:-moz-placeholder{color:#fff;opacity:1}::-moz-placeholder{color:#fff;opacity:1}:-ms-input-placeholder{color:#fff}img{max-width:100%;height:auto;vertical-align:top}.media-box iframe{width:100%;height:auto}@media (min-width: 1260px){.desktop-large_hidden {display: none !important;}.desktop-large_visible{display: block !important;}}@media (min-width: 1024px) and (max-width: 1260px){.desktop-small_hidden{display: none !important;}.desktop-small_visible{display: block !important;}}@media (min-width: 320px) and (max-width: 767px){.mobile_hidden{display:none !important}.mobile_visible{display:block !important}}@media (min-width: 768px) and (max-width: 1023px){.tablet_hidden{display:none !important}.tablet_visible{display:block !important}}</style>
  <link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__HPZzeVUkLT68D1FJTmzQto_2nl_dTK2F4C6ByyI-3Lw__YWa25Sh5pYu4XTzwg-N6B8w7Jx0Vh80vJQobD_eqNKc__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__2s4LqmS7ajL_KL-83VOLNecXRUa0_NAbMWIwTIdvTts__YuoyovkbmHwxLlrZHLKnw5NoaojJrrSU-wvZaGcqXKg__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__ZXyMdBl0buLF8vLGEao7S86RM2CjJz0jVh1zJsNr_Zg__SOEpjpUBnWWE2_JN2f--e5_YxWOtkCh9ZAupV88y-FA__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__5P_0jIZnMez5K_C4iVqitqQABi6t0hv0ofNOh9qkdx8__RgsDjfBGPnQdIzJY9taMYyn3Us0vafGLz8pn4VmtwvE__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.css" media="all" />
  <!-- Script for catch errors on Js error testing.
       It should goes before Drupal scripts array and any placed script -->
  <script>
    window.jsErrors = [];
    window.onerror = function(errorMessage) {
      window.jsErrors[window.jsErrors.length] = errorMessage;
    };
  </script>
  <script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__dU859nniAHOO3ZZ49DZUXr5Frl9T3QSa81hYdDf9Uas__JILlNGib1Hz87izGwrCoeUVWHEurARtSrto0pJK-26Q__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var mpscall = {"site":"rsn-web","path":"\/node\/1086991","title":"Need to Know: Setting the odds on the Redskins&#039; top draft pick one last time","qs":"cD15YTVuYmNzJm9jaWQ9eWFob28meXB0cj15YWhvbz9zcmM9cnNz","content_id":"node1086991","is_content":"1","type":"article","cag":{"author":"Rich-Tandler","field-bean-single-col":"Redskins-7-round-mock-draft","league":"NFL","section":"Washington-Redskins","sport":"Football","tags":"Latest-Headlines|Need-to-Know|Real-Redskins|Redskins-draft|Redskins-Top-Stories","team":"Washington-Redskins","field-videos":"Could-the-Redskins-take-a-chance-on-Reuben-Foster"},"pubdate":"1493247365"}
var mpsopts = {"host":"mps.nbcuni.com","updatecorrelator":"1"}
var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.gptloaded=mps._queue.gptloaded||[];mps.__timer=Date.now();mps.__intcode="v2"; "function"!=typeof mps.getAd&&(mps.getAd=function(a){if("string"!=typeof a)return!1;var b="mps-getad-"+a.replace(/\W/g,"");mps._ext&&mps._ext.loaded||(mps._queue.gptloaded.push(function(){"function"==typeof mps._gptfirst&&mps._gptfirst();mps.insertAd("#"+b,a)}),mps._adsheld.push(a));return'<div id="'+b+'" class="mps-wrapper" data-mps-fill-slot="'+a+'"></div>'});(function(){head=document.head||document.getElementsByTagName("head")[0];mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__lj8t3ZR9OqxjIdO80SOoTUeOBlfyvG2iv79lCDM3QBQ__V2hfJDBXK4gkwi4KglCyTp89c9iUvEm_w_q7gs3-ZFw__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__ZPSNIc2V1mJcmCsS8dAa4wjhJEDPUDXiLclnt1wyQJo__RJ9xi9wU_oAnYHhFY0XWtFBkVimQ6UfUNThk7quaoZA__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js" async="async"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js___Weo722cMICqp_44WWk_lcjyIQB-yadh-caReRrGI18__O4A57Sv5pz88_XnltO_gB5wHXvKWgKesy_ZA-iNCclg__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js" async="async"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__j_mvU6GjInKTuW3uzP34uzA_5OlaotUyiatneT2SiWY__97TX66XCItf69p6-4twvumMIpchbZVLDVdG7Ce3zN1A__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'), document.getElementsByTagName('script')[0], 'http://cdn.taboola.com/libtrc/nbcsports-csnwashington/loader.js');
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__UpIagL88__z0aKsv0IxjQ4mipVSe24kwfI5ue003iEU___WyM6b0R1KGOdVG5wfY5ByA_ESETPB9TpoBHvivcNU8__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.__gigyaConf = {"enabledProviders":"*","sessionExpiration":2000000,"connectWithoutLoginBehavior":"loginExistingUser"}
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.gigya.com/JS/socialize.js?apikey=2_0TqLS-kxDBlZLg4oGwYVgfuS20JKVamhsqmCTqo6ZPCzr6mXs_6dN5VjSh7mnAUm&amp;lang=en"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__NRBPtqXMfbnJnF-PrIangoYFOAhOS15PVR831iTDPYc__neeA2WYzvW7iFDxEaMLmZeh0A_inBsJJmSp2FuF-9ks__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__vgkAU7ftKvruRwfVcgbGzRP4sejSp5trysC_1C5Rtbo__qZ94Wuw8nP9OidqrZTPVyh5pF2ogBAbTpvL9ZYpwd7I__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__BHbH70wS7-F90kHyP54oL4hqEmk1FqPhmrI9TPl8Tak__ml4144ZU23dDWLgm95iCVeMdpCa_uz8znrMUGpmoZN0__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-1086991 node-type-article rsn-site rsn-site-csnma has-two-sidebars" >
    
  <header id="nbcsports-fixed-header">

    <!-- start Primary Nav -->
    <nav id="nbcsports-primary-nav">
                  <a href="http://www.csnmidatlantic.com" id="home-page-link"></a>  <a href="http://www.csnmidatlantic.com/washington-capitals" class="dynamic-nav-link" data-tid="231">Capitals</a>  <a href="http://www.csnmidatlantic.com/washington-wizards" class="dynamic-nav-link" data-tid="246">Wizards</a>  <a href="http://www.csnmidatlantic.com/washington-redskins" class="dynamic-nav-link" data-tid="191">Redskins</a>  <a href="http://www.csnmidatlantic.com/baltimore-ravens" class="dynamic-nav-link" data-tid="196">Ravens</a>  <a href="http://www.csnmidatlantic.com/washington-nationals" class="dynamic-nav-link" data-tid="216">Nationals</a>  <a href="http://www.csnmidatlantic.com/baltimore-orioles" class="dynamic-nav-link" data-tid="211">Orioles</a>  <a href="http://www.csnmidatlantic.com/ncaa" class="dynamic-nav-link" data-tid="291">NCAA</a>  <a href="http://www.csnmidatlantic.com/junkies" class="dynamic-nav-link" data-tid="10766">Sports Junkies</a>  <a href="http://www.csnmidatlantic.com/video" class="dynamic-nav-link" data-tid="126">Video</a>  <a href="http://www.csnmidatlantic.com/soccer" class="dynamic-nav-link" data-tid="26">Soccer</a>  <a href="http://www.csnmidatlantic.com/golf" class="dynamic-nav-link" data-tid="296">Golf</a>  <a href="http://www.csnmidatlantic.com/tomboy" class="dynamic-nav-link">TOMBOY</a>  <a href="http://www.csnmidatlantic.com/vote" class="dynamic-nav-link">Live Vote</a>  <a href="http://csntriviachallenge.com/" target="_blank" class="dynamic-nav-link">Trivia Challenge</a>  <a href="http://www.csnmidatlantic.com/mcm" class="dynamic-nav-link">Marine Corps Marathon</a>
<span id="more-nav-btn" class="no-select no-more-links" unselectable="on" tabindex="0">MORE</span>
    </nav>
    <!-- end Primary Nav -->

    <!-- start More Nav -->
    <nav id="more-nav" class="no-more-links">
    </nav>
    <!-- end More Nav -->

    <!-- start Secondary Nav -->
    <nav id="nbcsports-secondary-nav">
        
<div class="nbcsports-secondary-nav__wrapper">

        <a href="http://www.csnmidatlantic.com/video/category/796">Video</a>        <a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a>        <a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a>        <a href="http://stats.csnmidatlantic.com/fb/standings.asp">Standings</a>        <a href="http://stats.csnmidatlantic.com/fb/teamstats.asp?tm=28&amp;type=schedules">Schedule</a>        <a href="http://stats.csnmidatlantic.com/fb/teamstats.asp?teamno=28&amp;type=stats">Stats</a>        <a href="https://www.stubhub.com/washington-redskins-tickets/performer/6162/?gcid=chAFF-_-geoUS-_-genNFL-_-dt170602-_-cmpCSNMA_NFL-_-partNBCSports">Tickets</a>        <a href="http://www.rotoworld.com" class="rotoworld-nav">Rotoworld</a>        <a href="http://www.golfchannel.com" class="golf-channel-nav">Golf Channel </a>        <a href="http://www.comcastsportsnet.com" class="rsn-local-nav">Comcast SportsNet</a>  
  <div id="nbcsports-search-box">
    <form action="http://www.csnmidatlantic.com/search" class="search-form" method="get" autocomplete="off">
      <span class="icon"></span>
      <label>Search</label>
      <input type="search" name="search_api_views_fulltext" id="nbcsports-search" placeholder="Search CSN Mid-Atlantic" tabindex="0"/>
    </form>
  </div>

</div>
    </nav>
    <!-- end Secondary Nav -->

  </header>
  <!-- end #nbcsports-fixed-header -->

  <div id="wrapper">
    <div id="outer">
      <!-- Start leaderboard -->
      <div id="nbcsports-leaderboard">
                    <div class="region region-top-region">
    <div id="block-mps-topbanner" class="block block-mps">

    
  <div class="content">
    <div id="topbanner"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('topbanner'));</script></div>  </div>
</div>
  </div>
              </div>
      <!-- End leaderboard -->

      <!-- Start scoreboard -->
              <div id="nbcsports-scoreboard">
            <div class="region region-scoreboard">
    <div class="scoreboard with_ad">
  <iframe id="scoreboard-ticker" src="http://csnmidatlantic.stats.com/score_ticker/index.html?sports=LOCAL%7CNFL%7CNHL%7CMLB%7CNBA%7CNASCAR%7CCFB%7CCBK%7CEPL%7CFORM1%7CGOLF%7CMLS%7CCYCLING"></iframe>
</div>
<div id="block-mps-scorelogo" class="block block-mps">

    
  <div class="content">
    <div id="scorelogo"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('scorelogo'));</script></div>  </div>
</div>
  </div>
        </div>
            <!-- Start scoreboard -->

      <!-- Start content wrapper -->
      <div id="nbcsports-content-wrapper">

        <aside id="nbcsports-live-extra-widget">
                        <div class="region region-left-rail">
    <div id="block-bean-highlights-vod-redskins" class="block block-bean">

    
  <div class="content">
    <div  class="vod-content">
  <a href="http://www.csnmidatlantic.com/live" class="link link_type-block"><div class=""></div></a>
  <header class="title vod-content__title">
    <span class="title-text">Latest Videos</span>
  </header>
  <div class="vod-content__scrollbox">
    <div class="vod-content__events" id="vod-touch-events">
      <div class="events-list vod-content__events-list">
        <ul class="list events-list__list">
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1087321" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/junkies-deadlocked-voting-redskins-pick-no-17">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=v5v45yyq&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=VzHSmIwo&amp;timestamp=1493304310 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=v5v45yyq&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=VzHSmIwo&amp;timestamp=1493304310 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=v5v45yyq&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=VzHSmIwo&amp;timestamp=1493304310 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=v5v45yyq&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=VzHSmIwo&amp;timestamp=1493304310 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=v5v45yyq&amp;timestamp=1493304310" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">5:08</div>
                  </span>
        <span class="media-thumb__title">Junkies deadlocked voting on Redskins pick at No. 17</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1087306" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/redskins-may-eye-christian-mccaffrey-all-bets-if-jonathan-allen-falls">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=RFpSr3W2&amp;timestamp=1493303414 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=YK_tnhGp&amp;timestamp=1493303414 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=RFpSr3W2&amp;timestamp=1493303414 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=YK_tnhGp&amp;timestamp=1493303414 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=RFpSr3W2&amp;timestamp=1493303414 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=YK_tnhGp&amp;timestamp=1493303414 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=RFpSr3W2&amp;timestamp=1493303414 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=YK_tnhGp&amp;timestamp=1493303414 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/27/2017-04-27t12-08-05.066z-1280x720.jpg?itok=RFpSr3W2&amp;timestamp=1493303414" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:57</div>
                  </span>
        <span class="media-thumb__title">Skins could eye McCaffrey, but all bets off if Allen falls</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1086901" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/josh-norman-reflects-his-first-year-redskins">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=VlUcqcX6&amp;timestamp=1493240102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=Vu0UThc9&amp;timestamp=1493240102 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=VlUcqcX6&amp;timestamp=1493240102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=Vu0UThc9&amp;timestamp=1493240102 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=VlUcqcX6&amp;timestamp=1493240102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=Vu0UThc9&amp;timestamp=1493240102 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=VlUcqcX6&amp;timestamp=1493240102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=Vu0UThc9&amp;timestamp=1493240102 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/webversion_josh_norman_rn_4-26lowvideo_1920x1080_930152003887.jpg?itok=VlUcqcX6&amp;timestamp=1493240102" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">6:53</div>
                  </span>
        <span class="media-thumb__title">Josh Norman reflects on his first year with the Redskins</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1086762" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/will-redskins-draft-replacement-kirk-cousins">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=we0RFGYi&amp;timestamp=1493221202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=p6WgQmK9&amp;timestamp=1493221202 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=we0RFGYi&amp;timestamp=1493221202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=p6WgQmK9&amp;timestamp=1493221202 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=we0RFGYi&amp;timestamp=1493221202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=p6WgQmK9&amp;timestamp=1493221202 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=we0RFGYi&amp;timestamp=1493221202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=p6WgQmK9&amp;timestamp=1493221202 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=we0RFGYi&amp;timestamp=1493221202" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">4:38</div>
                  </span>
        <span class="media-thumb__title">Will the Redskins draft a replacement for Kirk Cousins?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1086921" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/are-redskins-going-draft-quarterback-replace-kirk-cousins">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=wcYHSij4&amp;timestamp=1493240413 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=Yz3WoJ8f&amp;timestamp=1493240413 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=wcYHSij4&amp;timestamp=1493240413 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=Yz3WoJ8f&amp;timestamp=1493240413 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=wcYHSij4&amp;timestamp=1493240413 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=Yz3WoJ8f&amp;timestamp=1493240413 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=wcYHSij4&amp;timestamp=1493240413 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=Yz3WoJ8f&amp;timestamp=1493240413 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720.jpg?itok=wcYHSij4&amp;timestamp=1493240413" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">4:38</div>
                  </span>
        <span class="media-thumb__title">Are the Redskins going to draft a quarterback this year?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1086632" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/could-redskins-take-chance-reuben-foster">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=nr2DpS-f&amp;timestamp=1493209202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=I2zr_0tt&amp;timestamp=1493209202 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=nr2DpS-f&amp;timestamp=1493209202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=I2zr_0tt&amp;timestamp=1493209202 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=nr2DpS-f&amp;timestamp=1493209202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=I2zr_0tt&amp;timestamp=1493209202 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=nr2DpS-f&amp;timestamp=1493209202 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=I2zr_0tt&amp;timestamp=1493209202 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=nr2DpS-f&amp;timestamp=1493209202" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:07</div>
                  </span>
        <span class="media-thumb__title">Could the Redskins take a chance on Reuben Foster?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1086546" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/what-chances-do-redskins-have-grabbing-jonathan-allen">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/usatsi_9800629_0.jpg?itok=xzDswI1A&amp;timestamp=1493180686 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/usatsi_9800629_0.jpg?itok=z7fxEf9g&amp;timestamp=1493180686 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/usatsi_9800629_0.jpg?itok=xzDswI1A&amp;timestamp=1493180686 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/usatsi_9800629_0.jpg?itok=z7fxEf9g&amp;timestamp=1493180686 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/usatsi_9800629_0.jpg?itok=xzDswI1A&amp;timestamp=1493180686 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/usatsi_9800629_0.jpg?itok=z7fxEf9g&amp;timestamp=1493180686 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/usatsi_9800629_0.jpg?itok=xzDswI1A&amp;timestamp=1493180686 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/26/usatsi_9800629_0.jpg?itok=z7fxEf9g&amp;timestamp=1493180686 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/26/usatsi_9800629_0.jpg?itok=xzDswI1A&amp;timestamp=1493180686" alt="Jonathan Allen USAT" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:11</div>
                  </span>
        <span class="media-thumb__title">What chances do Redskins have of grabbing Jonathan Allen?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1086476" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/actor-michael-ealy-talks-redskins-memories-career">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=5-XD5zIG&amp;timestamp=1493167778 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=aTaQs5rV&amp;timestamp=1493167778 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=5-XD5zIG&amp;timestamp=1493167778 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=aTaQs5rV&amp;timestamp=1493167778 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=5-XD5zIG&amp;timestamp=1493167778 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=aTaQs5rV&amp;timestamp=1493167778 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=5-XD5zIG&amp;timestamp=1493167778 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=aTaQs5rV&amp;timestamp=1493167778 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/04/25/screen_shot_2017-04-25_at_8.48.28_pm_0.png?itok=5-XD5zIG&amp;timestamp=1493167778" alt="Michael Ealy Redskins Nation" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">4:25</div>
                  </span>
        <span class="media-thumb__title">Actor Michael Ealy talks Redskins memories, career</span>
      </a>
          </div>
  </div>
  </li>
                  </ul>
      </div>
    </div>
  </div>
  <footer class="vod-content__footer"></footer>
</div>
  </div>
</div>
  </div>
                  </aside>

        <!-- Start main content -->
        <div id="nbcsports-main" class="clearfix">

                      <div class="tabs">
                          </div>
          
          
                      <div id="nbcsports-content-header" class="content-header content-header_full-width">
                <div class="region region-header">
    <div id="block-nbcs-article-nbcs-article-subscription-bar" class="block block-nbcs-article">

    
  <div class="content">
    
<header id="article-nav">
      <div id="article-social-nav">
      <a href="http://www.csnmidatlantic.com/washington-redskins" class="blog-name">Washington Redskins</a>      <span class="blog-social-buttons">
                <span class="social-button-text"></span>
        <span class="blog-social-button-container">
                      <a href="https://www.facebook.com/csnma" class="genericon genericon-facebook" target="_blank"></a>                      <a href="/rss/section/washington-redskins" class="genericon genericon-feed" target="_blank"></a>                      <a href="/alerts" class="genericon genericon-phone" target="_blank"></a>                      <a href="http://email.comcastsportsnet.com/csn/prefw.do" class="genericon genericon-mail" target="_blank"></a>                      <a href="https://twitter.com/CSNRedskins" class="genericon genericon-twitter" target="_blank"></a>                  </span>
              </span>
    </div>
    <!-- #article-social-nav -->
</header>  </div>
</div>
  </div>
            </div>
          
          <div class="main-layout">
            <div class="layout_full-minus-right layout_first dynamic-lede">
              <div class="content-inner">
                                              </div>
            </div>

            <div class="layout_full-minus-right layout_second dynamic-lede">
                <div class="content-inner">
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div class="articles--vod-player-fixed-container"></div>
<div class="articles__wrapper articles__node" data-taxonomy-term="191" data-vocabulary="6" data-active="1086991">
  <div class="articles">
    
<article id="post-1086991" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <h3 class="article-trending-nav-prefix">Quick Links</h3><ul class="article-trending-nav"><li class="menu-4891 first"><a href="http://www.csnmidatlantic.com/baltimore-ravens/2017-nfl-mock-draft-80-two-weeks-draft-day">Mock Draft</a></li>
<li class="menu-4206"><a href="/video/general/redskins">Redskins Videos</a></li>
<li class="menu-4436"><a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a></li>
<li class="menu-4201 last"><a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-1086991"></div>
  <span id='chrome-data-post-1086991' class="hidden" data-chrome='{"league":"nfl","sport":"football","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Need to Know: Setting the odds on the Redskins' top draft pick one last time    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-1086991"
         href="http://www.csnmidatlantic.com/video/could-redskins-take-chance-reuben-foster"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/midatlantic_article/select/media/Y0rTlKm3a_AX?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/2017-04-26t10-48-13.897z-1280x720.jpg?itok=2Bfo4Ha5" width="656" height="369" alt="2017-04-26t10-48-13.897z-1280x720.jpg" title="Could the Redskins take a chance on Reuben Foster?" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Need to Know: Setting the odds on the Redskins' top draft pick one last time    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/rich-tandler">Rich Tandler</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnmidatlantic.com/washington-redskins/need-know-setting-odds-redskins-top-draft-pick-one-last-time"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">April 27, 2017 5:00 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-1086991" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-1086991" id="comments-link-1086991" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-1086991">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-hero media-card_single-1-story">
      <h3 class="media-card__title">
      Redskins 7-round mock draft    </h3>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-1086722" class="colorbox-node colorbox-media-overlay link" href="/washington-redskins/redskins-full-seven-round-mock-draft">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1086722" class="colorbox-node colorbox-media-overlay link" href="/washington-redskins/redskins-full-seven-round-mock-draft">
      <span>Tandler&#039;s Redskins seven-round mock draft</span>
    </a>
  </h3>

      <p  class="story__text">
      Redskins insider Rich Tandler takes his final go at predicting the players 
the team will take starting Thursday night.

    </p>
  </div>
      </div>
</div>
          </div>
    <p>Here is what you need to know on this Thursday, April 27,&nbsp;27 days before the Redskins start OTAs on May 24.</p>
<p><strong>Timeline</strong></p>
<p><strong>Days until</strong>:<br><br>—Redskins rookie camp (5/12) 15<br>—Redskins OTAs start (5/24) 27<br>—Training camp starts (7/27) 91<br>—Redskins opener vs. Eagles (9/10) 136</p>
<p><strong>Setting the odds one last time</strong></p>
<p>So, today’s the day for the NFL draft and our final chance to make some Monopoly money on who the Redskins first-round pick will be. I’ve chosen five names from the various mock drafts out there and from my own analysis to come up with the five most likely players to be picked at No. 17. Then I broke out the imaginary $100 in casino chips and spread them out on the five players.</p>
<p><strong>LB Haason Reddick, Temple, $30—</strong>Reddick could give the Redskins some versatility and learn the inside linebacker spot in the base 3-4 defense and then move to the edge in nickel situations. I’m nearing he’s a “hot” name but I’m not so sure I believe he’s a top-10 pick like I’ve been seeing in some mock drafts lately. Pick 17 seems to be about right for him.</p>
<p><strong>LB Reuben Foster, Alabama, $20—</strong>Foster has more red flags than an interstate highway construction project, including a diluted drug test sample at the combine, multiple shoulder injuries, and getting upset during a wait for a medical test, also at the combine. But at some point, the talent makes the player too good a value to pass up at that point would be at No. 17.</p>
<p><strong>Edge Takkarist McKinley, UCLA, $20—</strong>Of the five names on here this is the one with the least buzz. But the Redskins need an edge rusher and McKinley, who can win with speed and by being relentless, may be the best one available. A lot of fans may be surprised by this pick but nobody should be mad if it happens.</p>
<p><strong>RB Dalvin Cook, Florida State, $20—</strong>I’ve been going back and forth about Cook. He’s undoubtedly a talented runner with breakaway potential. But some injury concerns and his fumbling problems create doubts about him. Then again, as with Foster there is a point where the talent outweighs the flags. I’m not so sure that No. 17 is the spot where that happens but I would not be shocked if the Redskins think that it is.</p>
<p><strong>RB Christian McCaffrey, Stanford, $10—</strong>This is another player who supposedly zoomed up draft boards over the last few weeks without playing a single down. Five or six weeks ago he was a late first-round pick. Then he was a lock to go to the Eagles at 14 overall. Now everyone has him going to the Panthers with the eighth pick. The movement seems to be based more on pack journalism rather than any actual information coming out of teams. I’m not going to completely dismiss the chatter but I think there is a good enough chance that McCaffrey will be there when the Redskins pick to throw a few long shot dollars on him.</p>
<p><strong>Bonus bet: </strong>As far as possible trades go, with an additional $100, I’ll go with $15 on a trade up, $35 on trade down, and $50 on staying put at 17.</p>
<p><em>Stay up to date on the Redskins. Rich Tandler covers the team 365 days a year. Like his Facebook page </em><a href="http://www.facebook.com/TandlerCSN"><em>Facebook.com/TandlerCSN</em></a><em> and follow him on Twitter </em><a href="https://twitter.com/Rich_TandlerCSN"><em>@Rich_TandlerCSN</em></a><em>.</em></p>
<p><strong>Tandler on Twitter</strong></p>
<p><blockquote class="twitter-tweet"><p lang="en" dir="ltr"><a href="https://twitter.com/MrDavidB21">@MrDavidB21</a> No way. The guy is a big enough risk to use one pick on. Zero chance I’d use three or even two on him. If he’s there, he’s there.</p>&mdash; Rich Tandler (@Rich_TandlerCSN) <a href="https://twitter.com/Rich_TandlerCSN/status/857275662016679937">April 26, 2017</a></blockquote>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
<p><strong>In case you missed it</strong></p>
<ul>
<li><a href="http://www.csnmidatlantic.com/washington-redskins/how-big-need-do-redskins-have-running-back">Do the Redskins really have a need at running back?</a></li>
<li><a href="http://www.csnmidatlantic.com/washington-redskins/final-redskins-seven-round-mock-draft-defense-first-surprise-third">In final full Redskins mock, front seven addressed 1-2 and then a surprise ...</a></li>
<li><a href="http://www.csnmidatlantic.com/washington-redskins/need-know-redskins-needs-line-well-strength-draft">Redskins’ needs line up well with the strength of the draft</a></li>
<li><a href="http://www.csnmidatlantic.com/baltimore-ravens/2017-nfl-mock-draft-110-final-version">2017 NFL Mock Draft 11.0</a></li>
<li><a href="http://www.csnmidatlantic.com/washington-redskins/when-talent-there-bruce-allen-has-looked-past-red-flags-1st-round-nfl-draft">When talent is right, Bruce Allen has looked past red flags at NFL Draft</a></li>
<li><a href="http://www.csnmidatlantic.com/washington-redskins/risk-vs-reward-when-redskins-consider-alabama-lb-reuben-foster-nfl-draft">Risk vs reward: Redskins considering Reuben Foster</a></li>
<li><a href="http://www.csnmidatlantic.com/washington-redskins/qb-run-will-come-nfl-draft-when-it-happens-matters-most-redskins">Redskins want QB run to happen early at NFL Draft</a></li>
</ul>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/latest-headlines" rel="tag">Latest Headlines</a>, <a href="/tags/need-know" rel="tag">Need to Know</a>, <a href="/tags/real-redskins" rel="tag">Real Redskins</a>, <a href="/tags/redskins-draft" rel="tag">Redskins draft</a>, <a href="/tags/redskins-top-stories" rel="tag">Redskins Top Stories</a></span>
        <div class="comments-container">
              <div id="respond-1086991">
          <div id="1086991" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-1086991"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-1086991"></div>
    <div id="taboola-container-text-links-post-1086991"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-1087366" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <h3 class="article-trending-nav-prefix">Quick Links</h3><ul class="article-trending-nav"><li class="menu-4891 first"><a href="http://www.csnmidatlantic.com/baltimore-ravens/2017-nfl-mock-draft-80-two-weeks-draft-day">Mock Draft</a></li>
<li class="menu-4206"><a href="/video/general/redskins">Redskins Videos</a></li>
<li class="menu-4436"><a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a></li>
<li class="menu-4201 last"><a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-1087366"></div>
  <span id='chrome-data-post-1087366' class="hidden" data-chrome='{"league":"nfl","sport":"football","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Former Redskins GM Scot McCloughan advising other teams in advance of NFL Draft, per NFL Network    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-1087366"
         href="http://www.csnmidatlantic.com/video/exclusive-redskins-bruce-allen-talks-scot-mccloughan-firing-draft-board"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/midatlantic_article/select/media/cnpe5iMLDDf0?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnma/files/styles/article_hero_image/public/2017/03/26/screen_shot_2017-03-26_at_7.32.56_pm.png?itok=RNPK6of4" width="656" height="369" alt="screen_shot_2017-03-26_at_7.32.56_pm.png" title="Exclusive: Redskins&#039; Bruce Allen talks Scot McCloughan firing, draft board" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Former Redskins GM Scot McCloughan advising other teams in advance of NFL Draft, per NFL Network    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/jp-finlay">JP Finlay</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnmidatlantic.com/washington-redskins/former-redskins-gm-scot-mccloughan-advising-other-teams-advance-nfl-draft-nfl"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">April 27, 2017 12:15 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-1087366" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-1087366" id="comments-link-1087366" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-1087366">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-headlines">
      <h3 class="media-card__title">
      Trending Now    </h3>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-1087321" class="link link_type-play link_type-block" href="/video/junkies-deadlocked-voting-redskins-pick-no-17">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=CGoaiEtl&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=bdwvoRHO&amp;timestamp=1493304310 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=CGoaiEtl&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=bdwvoRHO&amp;timestamp=1493304310 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=CGoaiEtl&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=bdwvoRHO&amp;timestamp=1493304310 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=CGoaiEtl&amp;timestamp=1493304310 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=bdwvoRHO&amp;timestamp=1493304310 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/27/2017-04-27t13-05-23.366z-1280x720.jpg?itok=CGoaiEtl&amp;timestamp=1493304310" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">5:08</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1087321" class="link" href="/video/junkies-deadlocked-voting-redskins-pick-no-17">
      <span>Junkies deadlocked voting on Redskins pick at No. 17</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-2">

      <div class="story__image">
              <a id="media-card-link-1087141" class="link link_type-play link_type-block" href="/video/ovechkin-vs-crosby-look-nhls-fiercest-rivalry">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=oEd3nI2S&amp;timestamp=1493262302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=zDHpON6y&amp;timestamp=1493262302 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=oEd3nI2S&amp;timestamp=1493262302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=zDHpON6y&amp;timestamp=1493262302 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=oEd3nI2S&amp;timestamp=1493262302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=zDHpON6y&amp;timestamp=1493262302 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=oEd3nI2S&amp;timestamp=1493262302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=zDHpON6y&amp;timestamp=1493262302 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t02-17-30.579z-1280x720.jpg?itok=oEd3nI2S&amp;timestamp=1493262302" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">3:20</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1087141" class="link" href="/video/ovechkin-vs-crosby-look-nhls-fiercest-rivalry">
      <span>Ovechkin vs Crosby: a look at the NHL&#039;s fiercest rivalry</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-3">

      <div class="story__image">
              <a id="media-card-link-1087076" class="link link_type-play link_type-block" href="/video/kelly-oubre-jr-proud-wizards-tenacious-defense">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=iGPNoxUJ&amp;timestamp=1493256302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=dEvo-6T1&amp;timestamp=1493256302 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=iGPNoxUJ&amp;timestamp=1493256302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=dEvo-6T1&amp;timestamp=1493256302 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=iGPNoxUJ&amp;timestamp=1493256302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=dEvo-6T1&amp;timestamp=1493256302 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=iGPNoxUJ&amp;timestamp=1493256302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=dEvo-6T1&amp;timestamp=1493256302 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t01-13-03.211z-1280x720.jpg?itok=iGPNoxUJ&amp;timestamp=1493256302" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:23</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1087076" class="link" href="/video/kelly-oubre-jr-proud-wizards-tenacious-defense">
      <span>Kelly Oubre Jr. is proud of Wizards&#039; tenacious defense</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-4">

      <div class="story__image">
              <a id="media-card-link-1087066" class="link link_type-play link_type-block" href="/video/and-down-wizards-bench-was-way-game-5">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=UmSEEbo5&amp;timestamp=1493256002 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=3CaaIMH4&amp;timestamp=1493256002 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=UmSEEbo5&amp;timestamp=1493256002 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=3CaaIMH4&amp;timestamp=1493256002 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=UmSEEbo5&amp;timestamp=1493256002 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=3CaaIMH4&amp;timestamp=1493256002 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=UmSEEbo5&amp;timestamp=1493256002 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=3CaaIMH4&amp;timestamp=1493256002 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/2017-04-27t00-57-46.795z-1280x720.jpg?itok=UmSEEbo5&amp;timestamp=1493256002" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">2:56</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1087066" class="link" href="/video/and-down-wizards-bench-was-way-game-5">
      <span>Up-and-down Wizards bench was way up in Game 5</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-5">

      <div class="story__image">
              <a id="media-card-link-1087061" class="link link_type-play link_type-block" href="/video/forget-stats-marcin-gortat-was-effective-game-5">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=4Br0gEcu&amp;timestamp=1493255191 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=jnV3YLak&amp;timestamp=1493255191 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=4Br0gEcu&amp;timestamp=1493255191 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=jnV3YLak&amp;timestamp=1493255191 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=4Br0gEcu&amp;timestamp=1493255191 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=jnV3YLak&amp;timestamp=1493255191 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=4Br0gEcu&amp;timestamp=1493255191 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=jnV3YLak&amp;timestamp=1493255191 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/04/26/screen_shot_2017-04-26_at_8.55.08_pm.png?itok=4Br0gEcu&amp;timestamp=1493255191" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:49</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1087061" class="link" href="/video/forget-stats-marcin-gortat-was-effective-game-5">
      <span>Forget the stats, Marcin Gortat was effective in Game 5</span>
    </a>
  </h3>

  </div>
      </div>
</div>
          </div>
    <p>Redskins team president Bruce Allen made clear at the NFL League Meetings that former general manager Scot McCloughan is free to work elsewhere in the NFL. Now it appears that's happening.&nbsp;</p>
<p>Mike Garafalo of the NFL Network reported that McCloughan has advised multiple NFL teams in advance of the draft.&nbsp;</p>
<p>McCloughan was let go by the Redskins in early March after a tumultuous few months following the 2016 season. A slew of reports pegged the GM's ouster on a combination of a power struggle with Allen and other outlets suggested problems with alcohol played a part in his firing.&nbsp;</p>
<p><strong><em><a href="http://www.csnmidatlantic.com/baltimore-ravens/2017-nfl-mock-draft-110-final-version">CLICK HERE FOR 2017 NFL MOCK DRAFT 11.0</a></em></strong></p>
<p>In previous stops with the 49ers and Seahawks, alcohol played a large role in McCloughan's removal from front office jobs. Before he was hired by Washington in 2015, McCloughan was operating his own scouting service.&nbsp;</p>
<p>Redskins director of college scouting Scott Campbell explained earlier this week that McCloughan played a part in setting the Redskins draft board. Campbell added, however, that much information on the board has changed since McCloughan was fired.</p>
<p>Outside of a small circle of people, it's hard to know exactly what transpired that led to McCloughan's firing. Regardless, it's not a surprise that he is back providing information about college prospects.&nbsp;</p>
<p><strong><em>MORE REDSKINS:&nbsp;<a href="http://www.csnmidatlantic.com/washington-redskins/nfl-draft-2017-going-22-deep-possible-redskins-first-round-picks" id="media-card-link-1087121">22 deep on possible Redskins first round picks</a></em></strong></p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/latest-headlines" rel="tag">Latest Headlines</a>, <a href="/tags/must-see" rel="tag">Must See</a>, <a href="/tags/redskins-top-stories" rel="tag">Redskins Top Stories</a></span>
        <div class="comments-container">
              <div id="respond-1087366">
          <div id="1087366" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-1087366"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-1087366"></div>
    <div id="taboola-container-text-links-post-1087366"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-1087286" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <h3 class="article-trending-nav-prefix">Quick Links</h3><ul class="article-trending-nav"><li class="menu-4891 first"><a href="http://www.csnmidatlantic.com/baltimore-ravens/2017-nfl-mock-draft-80-two-weeks-draft-day">Mock Draft</a></li>
<li class="menu-4206"><a href="/video/general/redskins">Redskins Videos</a></li>
<li class="menu-4436"><a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a></li>
<li class="menu-4201 last"><a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-1087286"></div>
  <span id='chrome-data-post-1087286' class="hidden" data-chrome='{"league":"nfl","sport":"football","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Five things to watch during the NFL draft while waiting for the Redskins to pick    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-1087286"
         href="http://www.csnmidatlantic.com/video/will-redskins-draft-replacement-kirk-cousins"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/midatlantic_article/select/media/hs4oET6oeD7j?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/2017-04-26t11-05-20.891z-1280x720_1.jpg?itok=2i7YbJA4" width="656" height="369" alt="2017-04-26t11-05-20.891z-1280x720.jpg" title="Will the Redskins draft a replacement for Kirk Cousins?" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Five things to watch during the NFL draft while waiting for the Redskins to pick    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/rich-tandler">Rich Tandler</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnmidatlantic.com/washington-redskins/five-things-watch-during-nfl-draft-while-waiting-redskins-pick"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">April 27, 2017 9:55 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-1087286" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-1087286" id="comments-link-1087286" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-1087286">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-hero media-card_single-1-story">
      <h3 class="media-card__title">
      Redskins 7-round mock draft    </h3>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-1086722" class="colorbox-node colorbox-media-overlay link" href="/washington-redskins/redskins-full-seven-round-mock-draft">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_2x_/public/2017/04/26/haason_reddick_usat.png?itok=86_SKgoC&amp;timestamp=1493217455 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/single_1__desktop_large_/public/2017/04/26/haason_reddick_usat.png?itok=yzWjsThc&amp;timestamp=1493217455" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1086722" class="colorbox-node colorbox-media-overlay link" href="/washington-redskins/redskins-full-seven-round-mock-draft">
      <span>Tandler&#039;s Redskins seven-round mock draft</span>
    </a>
  </h3>

      <p  class="story__text">
      Redskins insider Rich Tandler takes his final go at predicting the players 
the team will take starting Thursday night.

    </p>
  </div>
      </div>
</div>
          </div>
    <p>The Redskins have the 17th pick in tonight’s first round. Things get underway when the Browns go on the clock at about 8 p.m. There are 10 minutes allotted between picks. If each team takes the maximum time the Redskins will pick sometime after 11 p.m. However, picks are usually in with a few minutes to spare so Washington will go on the clock sometime between 10 and 10:30.</p>
<p>So, what is there to watch for until then? In what everything thinks will be one of the wildest and most unpredictable first rounds in recent memory, here are five places where the decisions made could have ripple effects back to pick No. 17.</p>
<p><strong>No. 1, Browns—</strong>The steaming hot rumor that has popped up in the last 24 hours is that QB Mitchell Trubisky, not DE Myles Garret, will be the top pick in the draft. Of course, that talk could be a steaming pile of, well, what comes out of the south end of a bull. If the Browns do go with Trubisky, who was expected to remain on the board through the first five picks, there could be a run on quarterbacks in the top half of the draft, with teams maneuvering to get their guy. That could push a solid defensive player back to the Redskins.</p>
<p><strong>No. 4, Jaguars—</strong>Nobody is quite sure what is going on here. Leonard Fournette is the chalk pick but this is the team that drafted Blake Bortles completely out of the blue in the top five a few years ago. They have spent a lot of draft capital and free agent money on defense. They may be ready to move on from Bortles so a QB is a possibility, a move that would start or, if Trubusky goes to the Browns at No. 1, continue a run on quarterbacks.</p>
<p><strong><em>RELATED:&nbsp;</em></strong><a href="http://www.csnmidatlantic.com/baltimore-ravens/2017-nfl-mock-draft-110-final-version"><strong><em>Final NFL Mock Draft</em></strong></a></p>
<p><strong>No. 8, Panthers—</strong>In a draft that is supposedly unpredictable, the constant in mock drafts over the last 10 days or so has been Christian McCaffrey to Carolina. It almost seems to be too simple to be true, especially if the top seven picks are loaded with surprises. The Panthers have plenty of needs and if they have a top safety or linebacker fall into their laps they could well bypass McCaffrey. That would put him in play for the Redskins at 17.</p>
<p><strong>No. 13, Cardinals—</strong>We go back to quarterbacks here. Will the Cardinals, who have plenty of needs, take a quarterback like Patrick Mahomes of Texas Tech to groom to replace Carson Palmer? If they do, that could force the a QB-needy team picking later in the first such as the Texans to move up to make sure they aren’t left out. That could have them on the phone to Ashburn offering their second-round pick to entice the Redskins to move down to No. 25.</p>
<p><strong><em>MORE REDSKINS: </em></strong><a href="http://www.csnmidatlantic.com/washington-redskins/final-redskins-seven-round-mock-draft-defense-first-surprise-third"><strong><em>Final Redskins mock: Defense goes 1-2, surprise in the third</em></strong></a>&nbsp;</p>
<p><strong>No. 16, Ravens—</strong>Picking immediately in front of the Redskins, the Ravens also have needs everywhere. Jonathan Allen and Reuben Foster seem like the type of player the Ravens like so there is the possibility that the Redskins could see a very good player at a top area of need slide back towards them only to get snatched up one pick prior to them going on the clock. The good news may be that many analysts have Baltimore addressing wide receiver or offensive line at No. 16 and those positions are not likely to be of high interest to the Redskins in the first round.</p>
<p><em>Stay up to date on the Redskins! Rich Tandler covers the team 365 days a year. Like his Facebook page </em><a href="http://www.facebook.com/TandlerCSN"><em>Facebook.com/TandlerCSN</em></a><em> and follow him on Twitter </em><a href="https://twitter.com/Rich_TandlerCSN"><em>@Rich_TandlerCSN</em></a><em>.</em></p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/latest-headlines" rel="tag">Latest Headlines</a>, <a href="/tags/real-redskins" rel="tag">Real Redskins</a>, <a href="/tags/redskins-draft" rel="tag">Redskins draft</a>, <a href="/tags/redskins-top-stories" rel="tag">Redskins Top Stories</a></span>
        <div class="comments-container">
              <div id="respond-1087286">
          <div id="1087286" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-1087286"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-1087286"></div>
    <div id="taboola-container-text-links-post-1087286"></div>
  </footer>
  <!-- .entry-footer -->
</article>
  </div>
  <div id="article-loadmore">
    <div class="footer_more-link">
      <a href="/articles/6/191/1" id="load_more_articles" class="use-ajax link link_type-block">Load more</a>    </div>
  </div>
</div>
  </div>
</div>
  </div>
                </div>
            </div>

                        <aside id="nbcsports-right-rail" class="sidebar sidebar_second">
                <div class="region region-right-rail">
    <div id="block-nbcs-article-nbcs-article-rail" class="block block-nbcs-article">

    
  <div class="content">
    <div id="story-explorer-wrapper">
 <aside id="story-explorer" class="styled-scrollbar">
    <div id="story-explorer-headlines">
      <div id="article-rail-ad"></div>
       <div id="article-rail-ad"></div>

<a href="/washington-redskins/former-redskins-gm-scot-mccloughan-advising-other-teams-advance-nfl-draft-nfl" class="story-explorer-item" id="headline-1087366">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/27/mccloughan-in-london-usat.png?itok=opxGBBB0" width="656" height="369" alt="mccloughan-in-london-usat.png" title="Former Redskins GM Scot McCloughan advising other teams in advance of NFL Draft, per NFL Network" /></span>
  <span class="item-headline">Former Redskins GM Scot McCloughan advising other teams in advance of NFL Draft, per NFL Network</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493310029"></span>
</a>

<a href="/washington-redskins/five-things-watch-during-nfl-draft-while-waiting-redskins-pick" class="story-explorer-item" id="headline-1087286">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/27/draft_stage_philly_ap.png?itok=Zj3MZJsS" width="656" height="369" alt="draft_stage_philly_ap.png" title="Five things to watch during the NFL draft while waiting for the Redskins to pick" /></span>
  <span class="item-headline">Five things to watch during the NFL draft while waiting for the Redskins to pick</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493302141"></span>
</a>

<a href="/washington-redskins/nfl-draft-2017-going-22-deep-possible-redskins-first-round-picks" class="story-explorer-item" id="headline-1087121">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/1st_round_picks.jpg?itok=FiYY2zUu" width="656" height="369" alt="1st_round_picks.jpg" title="NFL Draft 2017: Going 22 deep on possible Redskins first round picks" /></span>
  <span class="item-headline">NFL Draft 2017: Going 22 deep on possible Redskins first round picks</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493260226"></span>
</a>

<a href="/washington-redskins/need-know-setting-odds-redskins-top-draft-pick-one-last-time" class="story-explorer-item" id="headline-1086991">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/reuben_foster_2_usat.png?itok=tYcUiUkv" width="656" height="369" alt="reuben_foster_2_usat.png" title="Need to Know: Setting the odds on the Redskins&#039; top draft pick one last time" /></span>
  <span class="item-headline">Need to Know: Setting the odds on the Redskins' top draft pick one last time</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493247365"></span>
</a>

<a href="/washington-redskins/robert-kelley-sua-cravens-colt-mccoy-among-redskins-wholl-have-new-numbers-2017" class="story-explorer-item" id="headline-1086881">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/screen_shot_2017-04-26_at_4.11.37_pm.png?itok=PIl3x7kl" width="656" height="369" alt="screen_shot_2017-04-26_at_4.11.37_pm.png" title="Robert Kelley, Su&#039;a Cravens, Colt McCoy among Redskins who&#039;ll have new numbers in 2017" /></span>
  <span class="item-headline">Robert Kelley, Su'a Cravens, Colt McCoy among Redskins who'll have new numbers in 2017</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493237615"></span>
</a>

<a href="/washington-redskins/how-big-need-do-redskins-have-running-back" class="story-explorer-item" id="headline-1086796">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/christian_mccaffrey_running_usat.png?itok=qEk9zU_O" width="656" height="369" alt="christian_mccaffrey_running_usat.png" title="How big a need do the Redskins have at running back?" /></span>
  <span class="item-headline">How big a need do the Redskins have at running back?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493227240"></span>
</a>

<a href="/washington-redskins/when-talent-there-bruce-allen-has-looked-past-red-flags-1st-round-nfl-draft" class="story-explorer-item" id="headline-1086772">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/allen_talib.png?itok=Mt9xglXO" width="656" height="369" alt="allen_talib.png" title="When talent is there, Bruce Allen has looked past red flags in 1st round of NFL Draft" /></span>
  <span class="item-headline">When talent is there, Bruce Allen has looked past red flags in 1st round of NFL Draft</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493222807"></span>
</a>

<a href="/washington-redskins/risk-vs-reward-when-redskins-consider-alabama-lb-reuben-foster-nfl-draft" class="story-explorer-item" id="headline-1086757">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/usatsi_9800486_0.jpg?itok=cvKCfXki" width="656" height="369" alt="usatsi_9800486.jpg" title="Risk vs reward when Redskins consider Alabama LB Reuben Foster in NFL Draft" /></span>
  <span class="item-headline">Risk vs reward when Redskins consider Alabama LB Reuben Foster in NFL Draft</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493220687"></span>
</a>

<a href="/washington-redskins/final-redskins-seven-round-mock-draft-defense-first-surprise-third" class="story-explorer-item" id="headline-1086657">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/haason_reddick_2_usat.png?itok=GWxE8jqm" width="656" height="369" alt="haason_reddick_2_usat.png" title="Final Redskins seven-round mock draft: Defense first, a surprise in the third" /></span>
  <span class="item-headline">Final Redskins seven-round mock draft: Defense first, a surprise in the third</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493211755"></span>
</a>

<a href="/washington-redskins/qb-run-will-come-nfl-draft-when-it-happens-matters-most-redskins" class="story-explorer-item" id="headline-1086516">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/usatsi_9909761_0.jpg?itok=Q7xRpnUl" width="656" height="369" alt="usatsi_9909761.jpg" title="QB run will come at NFL Draft, but when it happens matters most for Redskins" /></span>
  <span class="item-headline">QB run will come at NFL Draft, but when it happens matters most for Redskins</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493172359"></span>
</a>

<a href="/washington-redskins/need-know-redskins-needs-line-well-strength-draft" class="story-explorer-item" id="headline-1086381">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/nfl-draft-scene.png?itok=xtYpxgo-" width="656" height="369" alt="nfl-draft-scene.png" title="Need to Know: Redskins’ needs line up well with the strength of the draft" /></span>
  <span class="item-headline">Need to Know: Redskins’ needs line up well with the strength of the draft</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493149779"></span>
</a>

<a href="/washington-redskins/redskins-2017-nfl-draft-preview-what-you-need-know-about-redskins-draft" class="story-explorer-item" id="headline-1086471">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/screen_shot_2017-04-25_at_7.45.32_pm.png?itok=ckRcn2Ft" width="656" height="369" alt="screen_shot_2017-04-25_at_7.45.32_pm.png" title="Redskins 2017 NFL Draft preview: What you need to know about the Redskins&#039; draft" /></span>
  <span class="item-headline">Redskins 2017 NFL Draft preview: What you need to know about the Redskins' draft</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493163998"></span>
</a>

<a href="/washington-redskins/kirk-cousins-tweets-about-signing-extension-dont-get-your-hopes-redskins-fans" class="story-explorer-item" id="headline-1086506">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/screenshot_20170425-210817.png?itok=tXSmH2ch" width="656" height="369" alt="screenshot_20170425-210817.png" title="Kirk Cousins tweets about signing an extension – but don&#039;t get your hopes up Redskins fans" /></span>
  <span class="item-headline">Kirk Cousins tweets about signing an extension – but don't get your hopes up Redskins fans</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493167829"></span>
</a>

<a href="/washington-redskins/impossible-probable-draft-day-slide-could-land-redskins-steal" class="story-explorer-item" id="headline-1086406">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/usatsi_9625519.jpg?itok=_nyNM9FY" width="656" height="369" alt="usatsi_9625519.jpg" title="Impossible to probable? Draft day slide could land Redskins a steal" /></span>
  <span class="item-headline">Impossible to probable? Draft day slide could land Redskins a steal</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493152706"></span>
</a>

<a href="/washington-redskins/will-christian-mccaffrey-last-until-redskins-pick-17-oddsmakers-weigh" class="story-explorer-item" id="headline-1086346">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/26/christian_mccaffrey.0.jpg?itok=8-rwpaO9" width="656" height="369" alt="christian_mccaffrey.0.jpg" title="Will Christian McCaffrey last until Redskins pick at 17? Oddsmakers weigh in " /></span>
  <span class="item-headline">Will Christian McCaffrey last until Redskins pick at 17? Oddsmakers weigh in </span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493146079"></span>
</a>

<a href="/washington-redskins/2017-redskins-depth-chart-preview-quarterback" class="story-explorer-item" id="headline-1086326">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/sudfeld-vs-jets-usat.png?itok=ehtCUOtt" width="656" height="369" alt="sudfeld-vs-jets-usat.png" title="2017 Redskins depth chart preview: Quarterback" /></span>
  <span class="item-headline">2017 Redskins depth chart preview: Quarterback</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493144610"></span>
</a>

<a href="/washington-redskins/new-redskinstalk-podcast-jp-tandler-break-down-redskins-draft-targets-and" class="story-explorer-item" id="headline-1086291">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/screen_shot_2017-04-25_at_1.46.17_pm.png?itok=mDNkMuKV" width="656" height="369" alt="screen_shot_2017-04-25_at_1.46.17_pm.png" title="New #RedskinsTalk Podcast: JP &amp; Tandler break down Redskins draft targets, and players to avoid" /></span>
  <span class="item-headline">New #RedskinsTalk Podcast: JP & Tandler break down Redskins draft targets, and players to avoid</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493142479"></span>
</a>

<a href="/washington-redskins/redskins-roster-numbers-defense" class="story-explorer-item" id="headline-1086266">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/redskins_defense_stretch_camp_usat.png?itok=PT6EXI-T" width="656" height="369" alt="redskins_defense_stretch_camp_usat.png" title="Redskins roster by the numbers: Defense" /></span>
  <span class="item-headline">Redskins roster by the numbers: Defense</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493138537"></span>
</a>

<a href="/washington-redskins/dale-earnhardt-jr-announces-retirement-nascar-after-2017" class="story-explorer-item" id="headline-1086236">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/dale_earnhardt_jr._usat.jpg?itok=yMd4cpIo" width="656" height="369" alt="dale_earnhardt_jr._usat.jpg" title="Dale Earnhardt Jr. announces retirement from NASCAR after 2017" /></span>
  <span class="item-headline">Dale Earnhardt Jr. announces retirement from NASCAR after 2017</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493134002"></span>
</a>

<a href="/washington-redskins/one-significant-stat-separates-christian-mccaffrey-dalvin-cook" class="story-explorer-item" id="headline-1086216">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/04/25/cook_mccaf_usat.jpg?itok=vAu1Ne6n" width="656" height="369" alt="cook_mccaf_usat.jpg" title="One significant stat that separates Christian McCaffrey from Dalvin Cook " /></span>
  <span class="item-headline">One significant stat that separates Christian McCaffrey from Dalvin Cook </span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1493132145"></span>
</a>
<div id="story-explorer-legal">
  </div>
    </div>
  </aside>
</div>
  </div>
</div>
  </div>
            </aside>
                      </div>

        </div>
        <!-- End main content -->

      </div>
      <!-- End content wrapper -->

      <!-- Start footer -->
      <footer id="nbcsports-footer">
          <div class="region region-footer">
    <div id="block-nbcs-footer-nbcs-footer" class="block block-nbcs-footer">

    
  <div class="content">
    <div id="footer-left">
  <div id="footer-logo"></div>
  <div id="footer-social-links">
    <span id="follow-us">FOLLOW US</span>
          <a href="http://facebook.com/CSNMA" class="genericon genericon-facebook">Facebook</a>          <a href="http://twitter.com/CSNMA" class="genericon genericon-twitter">Twitter</a>          <a href="http://instagram.com/CSNMA" class="genericon genericon-instagram">Instagram</a>      </div>
  <div id="copyright">©2017 Comcast SportsNet Mid-Atlantic, L.P.</div>
  <div id="footer-site-links">
          <a href="http://www.nbcuniversal.com/">A Division of NBC Universal</a>          <a href="http://www.nbcuniversal.com/privacy">Privacy Policy</a>          <a href="/terms_of_service">Terms of Service</a>          <a href="/contact">Contact Us</a>          <a href="http://www.csnmidatlantic.com/talent">Talent</a>          <a href="/advertise">Advertise</a>          <a href="http://www.csnmidatlantic.com/live-faq">Live FAQ</a>          <a href="http://www.nbcunicareers.com/search-results?search_type=criteria&amp;country=1&amp;state=23&amp;city=37&amp;keywords=">Jobs</a>          <a href="https://sjobs.brassring.com/TGWEbHost/jobdetails.aspx?partnerid=25354&amp;siteid=5108&amp;jobid=358293">Internships</a>          <a href="http://www.csnmidatlantic.com/press-releases/">Press Releases</a>          <a href="/ontv">TV Listings</a>          <a href="/rules">Sweepstakes</a>          <a href="/channel-finder">Channel Finder</a>          <a href="/alerts">Alerts</a>          <a href="http://email.comcastsportsnet.com/csn/prefw.do">Newsletters</a>          <a href="/page/closed-captioning">Closed Captioning</a>          <a href="http://corporate.comcast.com/news-information/nbcuniversal-transaction/independent-programming">Independent Programming Report</a>          <a href="http://info.evidon.com/pub_info/267?v=1">Ad Choices</a>      </div>
</div>
<div id="footer-right">
  <div id="footer-newsletter-link">
        <span id="newsletter-banner">GET NEWSLETTERS &amp; ALERTS</span>&#13;
    <a href="http://email.comcastsportsnet.com/csn/prefw.do" id="newsletter-link">SIGN UP</a>   </div>
</div>
  </div>
</div>
  </div>
      </footer>
      <!-- End footer -->

    </div><!-- end #outer -->
  </div><!-- end #wrapper -->
  <!-- SiteCatalyst code version: 1.7.0
Copyright 1996-2017 Adobe, Inc. -->
<script type="text/javascript" src="/sites/all/modules/custom/nbcs_sitecatalyst/js/nbcs_adobe.js?ooyi6p"></script>
<script type="text/javascript"><!--

var nbcscontenthub="nbcs.contenthub";
s.contextData[nbcscontenthub]="News";
var nbcsteam="nbcs.team";
s.contextData[nbcsteam]="Washington Redskins";
var nbcsleague="nbcs.league";
s.contextData[nbcsleague]="NFL";
var nbcssport="nbcs.sport";
s.contextData[nbcssport]="Football";
var nbcsauthor="nbcs.author";
s.contextData[nbcsauthor]="Rich Tandler";
var nbcssubfeature="nbcs.subfeature";
s.contextData[nbcssubfeature]="Washington Redskins";
var nbcscontenttype="nbcs.contenttype";
s.contextData[nbcscontenttype]="Story";
var nbcscontentid="nbcs.contentid";
s.contextData[nbcscontentid]="1086991";
var nbcscontenttitle="nbcs.contenttitle";
s.contextData[nbcscontenttitle]="Need to Know: Setting the odds on the Redskins\u0027 top draft pick one last time";
var nbcspagenumber="nbcs.pagenumber";
s.contextData[nbcspagenumber]=1;
var nbcsrelease_version="nbcs.release_version";
s.contextData[nbcsrelease_version]="1.26.1";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script>
<noscript><img src="http://examplecom.112.2O7.net/b/ss/examplecom/1/H.20.3--NS/0/1819794" height="1" width="1" alt=""></noscript>
<!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: 1.7.0 -->
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__lOCAh6_G2-syfSonbl_eRlz9mAnNDG7xohglRBwEoSo__GS5ds9kzIoBH1l_hrriHCM_VLQv5drEonElm4bMePaA__9qKG1AEe4QbqUVvyKKuxksCcN5d87R_opDKipeTWFPo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
typeof(mps)=='object' && typeof(mps.writeFooter)=='function' && mps.writeFooter();
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"cf07660617","applicationID":"15907363","transactionName":"ZQNbZ0cAX0UEABdcCVxJeFBBCF5YSg0MUQNtFlhUUD5HXwAU","queueTime":0,"applicationTime":576,"atts":"SURYEQ8aTEs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
