<!DOCTYPE html>
<html>
<head>
  <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.csnmidatlantic.com/misc/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="tp:EnableExternalController" content="true" />
<link rel="amphtml" href="http://www.csnmidatlantic.com/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens?amp" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57.png" rel="apple-touch-icon" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57-precomposed.png" rel="apple-touch-icon-precomposed" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72.png" rel="apple-touch-icon" sizes="72x72" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72-precomposed.png" rel="apple-touch-icon-precomposed" sizes="72x72" />
<meta name="description" content="The Redskins&#039; thoughts have turned to the Eagles and they have a longtime Redskin handling communicates with Su&#039;a Cravens." />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114.png" rel="apple-touch-icon" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114-precomposed.png" rel="apple-touch-icon-precomposed" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120-precomposed.png" rel="apple-touch-icon-precomposed" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144.png" rel="apple-touch-icon" sizes="144x144" />
<meta name="robots" content="follow, index" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144-precomposed.png" rel="apple-touch-icon-precomposed" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152-precomposed.png" rel="apple-touch-icon-precomposed" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180-precomposed.png" rel="apple-touch-icon-precomposed" sizes="180x180" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180" />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.csnmidatlantic.com/sites/csnma/files/2017/09/06/hall_usat.png" />
<link rel="canonical" href="http://www.csnmidatlantic.com/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens" />
<link rel="shortlink" href="http://www.csnmidatlantic.com/node/1149651" />
<meta property="og:site_name" content="CSN Mid-Atlantic" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.csnmidatlantic.com/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens" />
<meta property="og:title" content="DeAngelo Hall is Redskins’ point man in communications with Su&#039;a Cravens" />
<meta property="og:description" content="The Redskins&#039; thoughts have turned to the Eagles and they have a longtime Redskin handling communicates with Su&#039;a Cravens." />
<meta property="og:updated_time" content="2017-09-06T10:17:41-04:00" />
<meta property="og:image" content="http://www.csnmidatlantic.com/sites/csnma/files/2017/09/06/hall_usat.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="http://www.csnmidatlantic.com/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens" />
<meta name="twitter:title" content="DeAngelo Hall is Redskins’ point man in communications with Su&#039;a Cravens" />
<meta name="twitter:description" content="The Redskins&#039; thoughts have turned to the Eagles and they have a longtime Redskin handling communicates with Su&#039;a Cravens." />
<meta name="twitter:image" content="http://www.csnmidatlantic.com/sites/csnma/files/2017/09/06/hall_usat.png" />
<meta property="article:author" content="https://www.facebook.com/TandlerCSN/" />
<meta property="article:published_time" content="2017-09-06T09:26:53-04:00" />
<meta property="article:modified_time" content="2017-09-06T10:17:41-04:00" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
  <meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no">
  <title>DeAngelo Hall is Redskins’ point man in communications with Su'a Cravens | CSN Mid-Atlantic</title>
  <!-- Don't remove this. We are loading base file at first -->
  <style id="normalize-css">/*! normalize.css v7.0.0 */html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%}body{margin:0}article,aside,footer,header,nav,section{display:block}h1{font-size:2em;margin:.67em 0}figcaption,figure,main{display:block}figure{margin:1em 40px}hr{-webkit-box-sizing:content-box;box-sizing:content-box;height:0;overflow:visible}pre{font-family:monospace,monospace;font-size:1em}a{background-color:transparent;-webkit-text-decoration-skip:objects}abbr[title]{border-bottom:none;text-decoration:underline;text-decoration:underline dotted}b,strong{font-weight:inherit}b,strong{font-weight:bolder}code,kbd,samp{font-family:monospace,monospace;font-size:1em}dfn{font-style:italic}mark{background-color:#ff0;color:#000}small{font-size:80%}sub,sup{font-size:75%;line-height:0;position:relative;vertical-align:baseline}sub{bottom:-.25em}sup{top:-.5em}audio,video{display:inline-block}audio:not([controls]){display:none;height:0}img{border-style:none}svg:not(:root){overflow:hidden}button,input,optgroup,select,textarea{font-family:sans-serif;font-size:100%;line-height:1.15;margin:0}button,input{overflow:visible}button,select{text-transform:none}[type=reset],[type=submit],button,html [type=button]{-webkit-appearance:button}[type=button]::-moz-focus-inner,[type=reset]::-moz-focus-inner,[type=submit]::-moz-focus-inner,button::-moz-focus-inner{border-style:none;padding:0}[type=button]:-moz-focusring,[type=reset]:-moz-focusring,[type=submit]:-moz-focusring,button:-moz-focusring{outline:1px dotted ButtonText}fieldset{padding:.35em .75em .625em}legend{-webkit-box-sizing:border-box;box-sizing:border-box;color:inherit;display:table;max-width:100%;padding:0;white-space:normal}progress{display:inline-block;vertical-align:baseline}textarea{overflow:auto}[type=checkbox],[type=radio]{-webkit-box-sizing:border-box;box-sizing:border-box;padding:0}[type=number]::-webkit-inner-spin-button,[type=number]::-webkit-outer-spin-button{height:auto}[type=search]{-webkit-appearance:textfield;outline-offset:-2px}[type=search]::-webkit-search-cancel-button,[type=search]::-webkit-search-decoration{-webkit-appearance:none}::-webkit-file-upload-button{-webkit-appearance:button;font:inherit}details,menu{display:block}summary{display:list-item}canvas{display:inline-block}template{display:none}[hidden]{display:none}</style>
  <style>
    @media (min-width: 1260px) {
      .desktop-large_hidden {
        display: none !important;
      }

      .desktop-large_visible {
        display: block !important;
      }
    }

    @media (min-width: 1024px) and (max-width: 1260px) {
      .desktop-small_hidden {
        display: none !important;
      }

      .desktop-small_visible {
        display: block !important;
      }
    }

    @media (min-width: 320px) and (max-width: 767px) {
      .mobile_hidden {
        display: none !important
      }

      .mobile_visible {
        display: block !important
      }
    }

    @media (min-width: 768px) and (max-width: 1023px) {
      .tablet_hidden {
        display: none !important
      }

      .tablet_visible {
        display: block !important
      }
    }
    body {
      font: normal 12px Arial, Helvetica, sans-serif;
      line-height: 1.2;
    }
  </style>
  <link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__LqXDLOEdu4FjANrDpUp-e9hLLmTMujC_lNNowZP2pPk__4j7vksssq8uPKxjky87FDjEQeTo92tKxLYjUQ1GU1K8__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__4SRdXpmuWuU2BMGiwILZhNhn1u3DV3ODaqVjlT6DENI__En0q-9UfU7BKVMrcvT97xQ6hLjhdmiFdT6NyJfx3df4__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnmidatlantic.com/sites/csnma/files/advagg_css/css__CQcbxuyvk0Wvma12FiMG_E6nMSkn2ZZrdBiROWD29cY__lMF-NNFkSBiE3_f6CHzGr2UV7iXsXy36PcOAIWAGMBA__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.css" media="all" />
  <!-- Script for catch errors on Js error testing.
       It should goes before Drupal scripts array and any placed script -->
  <script>
    window.jsErrors = [];
    window.onerror = function(errorMessage) {
      window.jsErrors[window.jsErrors.length] = errorMessage;
    };
  </script>
  <script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__dU859nniAHOO3ZZ49DZUXr5Frl9T3QSa81hYdDf9Uas__z5nVZxB0doPg5UEpzqokYkC7se53_MdsNYhC6AiMB4k__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var mpscall = {"site":"rsn-web","path":"\/node\/1149651","title":"DeAngelo Hall is Redskins’ point man in communications with Su&#039;a Cravens","qs":"cD15YTVuYmNzJm9jaWQ9eWFob28meXB0cj15YWhvbz9zcmM9cnNz","content_id":"node1149651","is_content":"1","type":"article","cag":{"author":"Rich-Tandler","field-bean-single-col":"Latest-posts-on-Rich-Tandler-s-Real-Redskins","league":"NFL","section":"Washington-Redskins","sport":"Football","tags":"Latest-Headlines|Real-Redskins|Redskins-Top-Stories","team":"Washington-Redskins","field-videos":"Redskins-players-react-to-Su-a-Cravens-considering-retirement"},"pubdate":"1504704413"}
var mpsopts = {"host":"mps.nbcuni.com","updatecorrelator":"1"}
var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.gptloaded=mps._queue.gptloaded||[];mps.__timer=Date.now();mps.__intcode="v2"; "function"!=typeof mps.getAd&&(mps.getAd=function(a){if("string"!=typeof a)return!1;var b="mps-getad-"+a.replace(/\W/g,"");mps._ext&&mps._ext.loaded||(mps._queue.gptloaded.push(function(){"function"==typeof mps._gptfirst&&mps._gptfirst();mps.insertAd("#"+b,a)}),mps._adsheld.push(a));return'<div id="'+b+'" class="mps-wrapper" data-mps-fill-slot="'+a+'"></div>'});(function(){head=document.head||document.getElementsByTagName("head")[0];mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__lj8t3ZR9OqxjIdO80SOoTUeOBlfyvG2iv79lCDM3QBQ__V2hfJDBXK4gkwi4KglCyTp89c9iUvEm_w_q7gs3-ZFw__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__CNkwMrd76LbgBpe8m-LAi3EqnCzaRNMBlyiVQY-5YLU__y3uJNjMrk-UUz9riUnY4jl6wIVGTcQKJb32xDfioJfc__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js" async="async"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__j_mvU6GjInKTuW3uzP34uzA_5OlaotUyiatneT2SiWY__d4KrvF-Hp4grp7uWbf8Z49upKesx-nt8QSauELdwNzw__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'), document.getElementsByTagName('script')[0], 'http://cdn.taboola.com/libtrc/nbcsports-csnwashington/loader.js');
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__UpIagL88__z0aKsv0IxjQ4mipVSe24kwfI5ue003iEU___1kjavhG6aE-4CAyJ1RAdVcZplWy2WJrJDizmH9S6Ao__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.__gigyaConf = {"enabledProviders":"*","sessionExpiration":2000000,"connectWithoutLoginBehavior":"loginExistingUser"}
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.gigya.com/JS/socialize.js?apikey=2_0TqLS-kxDBlZLg4oGwYVgfuS20JKVamhsqmCTqo6ZPCzr6mXs_6dN5VjSh7mnAUm&amp;lang=en"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__-4oa_oJw2A_q1tOMBQnKV5zcwH1S6WxQg6d2DtAjG78__bEdRK3CajH2AIEer_fo6BnQOh6eGKpflFHA7evLl9JI__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__uGy7mdgzUszOO-WRuOLQb9vvxnC8ZlVHDkVKnh5mPaM__aPqdzCyNHTXVoa8D_d9e35nSYju54UwYh_uMUIR3CKU__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-1149651 node-type-article rsn-site rsn-site-csnma has-two-sidebars" >
    
  <header id="nbcsports-fixed-header">

    <!-- start Primary Nav -->
    <nav id="nbcsports-primary-nav">
                <div class="nbcsports-primary-nav__wrapper washington_redskins">

  <a href="http://www.csnmidatlantic.com" id="home-page-link"></a><a href="http://www.csnmidatlantic.com/washington-capitals" class="dynamic-nav-link nav-link" data-tid="231">Capitals</a><a href="http://www.csnmidatlantic.com/washington-wizards" class="dynamic-nav-link nav-link" data-tid="246">Wizards</a><a href="http://www.csnmidatlantic.com/washington-redskins" class="dynamic-nav-link nav-link" data-tid="191">Redskins</a><a href="http://www.csnmidatlantic.com/baltimore-ravens" class="dynamic-nav-link nav-link" data-tid="196">Ravens</a><a href="http://www.csnmidatlantic.com/washington-nationals" class="dynamic-nav-link nav-link" data-tid="216">Nationals</a><a href="http://www.csnmidatlantic.com/baltimore-orioles" class="dynamic-nav-link nav-link" data-tid="211">Orioles</a><a href="http://www.csnmidatlantic.com/podcasts" class="dynamic-nav-link nav-link">Podcasts</a><a href="http://www.csnmidatlantic.com/video" class="dynamic-nav-link nav-link" data-tid="126">Video</a><a href="http://www.csnmidatlantic.com/live-stream" class="dynamic-nav-link nav-link">Live Streams</a><a href="http://www.csnmidatlantic.com/junkies" class="dynamic-nav-link nav-link" data-tid="10766">Sports Junkies</a><a href="http://www.csnmidatlantic.com/ncaa" class="dynamic-nav-link nav-link" data-tid="291">NCAA</a><a href="http://www.csnmidatlantic.com/soccer" class="dynamic-nav-link nav-link" data-tid="26">Soccer</a><a href="http://www.csnmidatlantic.com/golf" class="dynamic-nav-link nav-link" data-tid="296">Golf</a><a href="http://www.csnmidatlantic.com/tomboy" class="dynamic-nav-link nav-link">TOMBOY</a><a href="http://csntriviachallenge.com/" target="_blank" class="dynamic-nav-link nav-link">Trivia Challenge</a>
  <span id="more-nav-btn" class="no-select no-more-links nav-link" unselectable="on" tabindex="0">MORE</span>

</div>
    </nav>
    <!-- end Primary Nav -->

    <!-- start More Nav -->
    <nav id="more-nav" class="no-more-links">
    </nav>
    <!-- end More Nav -->

    <!-- start Secondary Nav -->
    <nav id="nbcsports-secondary-nav">
        
<div class="nbcsports-secondary-nav__wrapper">

        <a href="http://www.csnmidatlantic.com/live-stream" class="nav-link">Live</a>        <a href="http://www.csnmidatlantic.com/video/category/796" class="nav-link">Video</a>        <a href="https://audioboom.com/channel/redskins-talk" class="nav-link">Podcast</a>        <a href="http://www.csnmidatlantic.com/author/jp-finlay" class="nav-link">JP Finlay</a>        <a href="http://www.csnmidatlantic.com/realredskins" class="nav-link">Real Redskins</a>        <a href="http://stats.csnmidatlantic.com/fb/standings.asp" class="nav-link">Standings</a>        <a href="http://stats.csnmidatlantic.com/fb/teamstats.asp?tm=28&amp;type=schedules" class="nav-link">Schedule</a>        <a href="http://stats.csnmidatlantic.com/fb/teamstats.asp?teamno=28&amp;type=stats" class="nav-link">Stats</a>        <a href="https://www.stubhub.com/washington-redskins-tickets/performer/6162/?gcid=chAFF-_-geoUS-_-genNFL-_-dt170602-_-cmpCSNMA_NFL-_-partNBCSports" class="nav-link">Tickets</a>        <a href="http://www.rotoworld.com" class="rotoworld-nav">Rotoworld</a>        <a href="http://www.golfchannel.com" class="golf-channel-nav">Golf Channel </a>        <a href="http://www.comcastsportsnet.com" class="rsn-local-nav">Comcast SportsNet</a>  
  <div id="nbcsports-search-box">
    <form action="http://www.csnmidatlantic.com/search" class="search-form" method="get" autocomplete="off">
      <span class="icon"></span>
      <label>Search</label>
      <input type="search" name="search_api_views_fulltext" id="nbcsports-search" placeholder="Search CSN Mid-Atlantic" tabindex="0"/>
    </form>
  </div>

</div>
    </nav>
    <!-- end Secondary Nav -->

  </header>
  <!-- end #nbcsports-fixed-header -->

  <div id="wrapper">
    <div id="outer">
      <!-- Start leaderboard -->
      <div id="nbcsports-leaderboard">
                    <div class="region region-top-region">
    <div id="block-block-11" class="block block-block">

    
  <div class="content">
    <style>

div.top-stories__separator {
    display:none;
}

</style>  </div>
</div>
<div id="block-mps-topbanner" class="block block-mps">

    
  <div class="content">
    <div id="topbanner"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('topbanner'));</script></div>  </div>
</div>
  </div>
              </div>
      <!-- End leaderboard -->

      <!-- Start scoreboard -->
              <div id="nbcsports-scoreboard">
            <div class="region region-scoreboard">
    <div class="scoreboard with_ad">
  <iframe id="scoreboard-ticker" src="http://csnmidatlantic.stats.com/score_ticker_lt/index.html?sports=LOCAL%7CNFL%7CNHL%7CMLB%7CNBA%7CNASCAR%7CCFB%7CCBK%7CEPL%7CFORM1%7CGOLF%7CMLS%7CCYCLING"></iframe>
</div>
<div id="block-mps-scorelogo" class="block block-mps">

    
  <div class="content">
    <div id="scorelogo"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('scorelogo'));</script></div>  </div>
</div>
  </div>
        </div>
            <!-- Start scoreboard -->

      <!-- Start content wrapper -->
      <div id="nbcsports-content-wrapper">

        <aside id="nbcsports-live-extra-widget">
                        <div class="region region-left-rail">
    <div id="block-bean-highlights-vod-redskins" class="block block-bean">

    
  <div class="content">
    <div  class="vod-content">
  <a href="http://www.csnmidatlantic.com/live" class="link link_type-block"><div class=""></div></a>
  <header class="title vod-content__title">
    <span class="title-text">Latest Videos</span>
  </header>
  <div class="vod-content__scrollbox">
    <div class="vod-content__events" id="vod-touch-events">
      <div class="events-list vod-content__events-list">
        <ul class="list events-list__list">
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1149551" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/junkies-chris-thompsons-value-team-all-time-high-right-now">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=QpgMvNi5&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=D6dzucTs&amp;timestamp=1504698231 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=QpgMvNi5&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=D6dzucTs&amp;timestamp=1504698231 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=QpgMvNi5&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=D6dzucTs&amp;timestamp=1504698231 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=QpgMvNi5&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=D6dzucTs&amp;timestamp=1504698231 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=QpgMvNi5&amp;timestamp=1504698231" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">0:45</div>
                  </span>
        <span class="media-thumb__title">Junkies: Thompson&#039;s value to team at all time high right now</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1149446" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/brian-mitchell-describes-many-skills-chris-thompson">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=XJa0U1X7&amp;timestamp=1504664881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=eSLWwxWI&amp;timestamp=1504664881 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=XJa0U1X7&amp;timestamp=1504664881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=eSLWwxWI&amp;timestamp=1504664881 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=XJa0U1X7&amp;timestamp=1504664881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=eSLWwxWI&amp;timestamp=1504664881 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=XJa0U1X7&amp;timestamp=1504664881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=eSLWwxWI&amp;timestamp=1504664881 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=XJa0U1X7&amp;timestamp=1504664881" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:15</div>
                  </span>
        <span class="media-thumb__title">Brian Mitchell describes the many skills of Chris Thompson</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1149381" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/healthy-josh-doctson-better-terrelle-pryor">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/ap_16262724788565_0.jpg?itok=uXV5ydxf&amp;timestamp=1504650959 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/ap_16262724788565_0.jpg?itok=EjHDiEvo&amp;timestamp=1504650959 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/ap_16262724788565_0.jpg?itok=uXV5ydxf&amp;timestamp=1504650959 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/ap_16262724788565_0.jpg?itok=EjHDiEvo&amp;timestamp=1504650959 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/ap_16262724788565_0.jpg?itok=uXV5ydxf&amp;timestamp=1504650959 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/ap_16262724788565_0.jpg?itok=EjHDiEvo&amp;timestamp=1504650959 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/ap_16262724788565_0.jpg?itok=uXV5ydxf&amp;timestamp=1504650959 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/ap_16262724788565_0.jpg?itok=EjHDiEvo&amp;timestamp=1504650959 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/ap_16262724788565_0.jpg?itok=uXV5ydxf&amp;timestamp=1504650959" alt="Josh Doctson diving AP" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">0:50</div>
                  </span>
        <span class="media-thumb__title">A healthy Josh Doctson is better than Terrelle Pryor</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1149271" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/jay-gruden-shows-compassion-towards-cravens-situation">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=mdE9Kv9O&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=bUKQupoS&amp;timestamp=1504637881 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=mdE9Kv9O&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=bUKQupoS&amp;timestamp=1504637881 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=mdE9Kv9O&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=bUKQupoS&amp;timestamp=1504637881 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=mdE9Kv9O&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=bUKQupoS&amp;timestamp=1504637881 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=mdE9Kv9O&amp;timestamp=1504637881" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">5:18</div>
                  </span>
        <span class="media-thumb__title">Jay Gruden shows compassion towards the Cravens situation</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1149031" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/junkies-sua-cravens-just-doesnt-have-passion-play-football">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=2oyOPLST&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=eKhTHhY2&amp;timestamp=1504608653 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=2oyOPLST&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=eKhTHhY2&amp;timestamp=1504608653 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=2oyOPLST&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=eKhTHhY2&amp;timestamp=1504608653 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=2oyOPLST&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=eKhTHhY2&amp;timestamp=1504608653 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=2oyOPLST&amp;timestamp=1504608653" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">2:28</div>
                  </span>
        <span class="media-thumb__title">Junkies: Cravens just doesn&#039;t have the passion for football</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1148601" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/spencer-long-talks-jp-finlay-after-returning-knee-surgery">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=nPhS-FXG&amp;timestamp=1504482305 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=zlepwzlc&amp;timestamp=1504482305 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=nPhS-FXG&amp;timestamp=1504482305 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=zlepwzlc&amp;timestamp=1504482305 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=nPhS-FXG&amp;timestamp=1504482305 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=zlepwzlc&amp;timestamp=1504482305 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=nPhS-FXG&amp;timestamp=1504482305 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=zlepwzlc&amp;timestamp=1504482305 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-27-51.966z-1280x720.jpg?itok=nPhS-FXG&amp;timestamp=1504482305" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:19</div>
                  </span>
        <span class="media-thumb__title">Spencer Long talks about returning from knee surgery</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1148576" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/colt-mccoy-dons-maryland-t-shirt-after-terps-beat-longhorns">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=yq8x8Jsq&amp;timestamp=1504479302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=qjUDS3eJ&amp;timestamp=1504479302 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=yq8x8Jsq&amp;timestamp=1504479302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=qjUDS3eJ&amp;timestamp=1504479302 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=yq8x8Jsq&amp;timestamp=1504479302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=qjUDS3eJ&amp;timestamp=1504479302 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=yq8x8Jsq&amp;timestamp=1504479302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=qjUDS3eJ&amp;timestamp=1504479302 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-07-04.9z-1280x720.jpg?itok=yq8x8Jsq&amp;timestamp=1504479302" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">0:41</div>
                  </span>
        <span class="media-thumb__title">Colt McCoy dons Maryland t-shirt after Terps beat Longhorns</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-1148556" class="colorbox-node colorbox-media-overlay link link_type-block link_type-play" href="http://www.csnmidatlantic.com/video/redskins-players-react-sua-cravens-considering-retirement">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=Sp6N9AvK&amp;timestamp=1504478102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=vMUxP1in&amp;timestamp=1504478102 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=Sp6N9AvK&amp;timestamp=1504478102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=vMUxP1in&amp;timestamp=1504478102 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=Sp6N9AvK&amp;timestamp=1504478102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=vMUxP1in&amp;timestamp=1504478102 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=Sp6N9AvK&amp;timestamp=1504478102 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_2x_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=vMUxP1in&amp;timestamp=1504478102 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_6__desktop_large_/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=Sp6N9AvK&amp;timestamp=1504478102" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:37</div>
                  </span>
        <span class="media-thumb__title">Redskins players react to Cravens considering retirement</span>
      </a>
          </div>
  </div>
  </li>
                  </ul>
      </div>
    </div>
  </div>
  <footer class="vod-content__footer"></footer>
</div>
  </div>
</div>
  </div>
                  </aside>

        <!-- Start main content -->
        <div id="nbcsports-main" class="clearfix">

                      <div class="tabs">
                          </div>
          
          
          
          <div class="main-layout">
            <div class="layout_full-minus-right layout_first dynamic-lede">
              <div class="content-inner">
                                              </div>
            </div>

            <div class="layout_full-minus-right layout_second dynamic-lede">
                <div class="content-inner">
                    <div class="region region-content">
    <div id="block-nbcs-article-nbcs-article-subscription-bar" class="block block-nbcs-article">

    
  <div class="content">
    
<header id="article-nav">
      <div id="article-social-nav">
      <a href="http://www.csnmidatlantic.com/washington-redskins" class="blog-name">Washington Redskins</a>      <span class="blog-social-buttons">
                <span class="social-button-text">Subscribe:</span>
        <span class="blog-social-button-container">
                      <a href="https://www.facebook.com/csnma" class="genericon genericon-facebook" target="_blank"></a>                      <a href="/rss/section/washington-redskins" class="genericon genericon-feed" target="_blank"></a>                      <a href="/alerts" class="genericon genericon-phone" target="_blank"></a>                      <a href="http://email.comcastsportsnet.com/csn/prefw.do" class="genericon genericon-mail" target="_blank"></a>                      <a href="https://twitter.com/CSNRedskins" class="genericon genericon-twitter" target="_blank"></a>                  </span>
              </span>
    </div>
    <!-- #article-social-nav -->
</header>
  </div>
</div>
<div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div class="articles--vod-player-fixed-container"></div>
<div class="articles__wrapper articles__node" data-taxonomy-term="191" data-vocabulary="6" data-active="1149651">
  <div class="articles">
    
<article id="post-1149651" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <h3 class="article-trending-nav-prefix">Quick Links</h3><ul class="article-trending-nav"><li class="menu-5046 first"><a href="/washington-redskins/2017-nfl-power-rankings-who-got-better-after-draft">Power Rankings</a></li>
<li class="menu-4206"><a href="/video/general/redskins">Redskins Videos</a></li>
<li class="menu-4436"><a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a></li>
<li class="menu-4201 last"><a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-1149651"></div>
  <span id='chrome-data-post-1149651' class="hidden" data-chrome='{"league":"nfl","sport":"football","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      DeAngelo Hall is Redskins’ point man in communications with Su'a Cravens    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-1149651"
         href="http://www.csnmidatlantic.com/video/redskins-players-react-sua-cravens-considering-retirement"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/midatlantic_article/select/media/uP2Lo7WpZzkD?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/03/2017-09-03t22-01-24.366z-1280x720.jpg?itok=JiTiwdrr" width="656" height="369" alt="2017-09-03t22-01-24.366z-1280x720.jpg" title="Redskins players react to Su&#039;a Cravens considering retirement" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      DeAngelo Hall is Redskins’ point man in communications with Su'a Cravens    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/rich-tandler">Rich Tandler</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnmidatlantic.com/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">September 06, 2017 10:15 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-1149651" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-1149651" id="comments-link-1149651" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-1149651">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-headlines">
      <h3 class="media-card__title">
      Latest posts on Rich Tandler's Real Redskins    </h3>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-1149651" class="link" href="/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149651" class="link" href="/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens">
      <span>Hall is Redskins’ point man in communications with Cravens</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-2">

      <div class="story__image">
              <a id="media-card-link-1149606" class="link" href="/washington-redskins/after-chris-thompson-deal-who-else-redskins-line-extension">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149606" class="link" href="/washington-redskins/after-chris-thompson-deal-who-else-redskins-line-extension">
      <span>After Thompson, who else on the Redskins is in line for an extension?</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-3">

      <div class="story__image">
              <a id="media-card-link-1149401" class="link" href="/washington-redskins/need-know-first-look-redskins-vs-eagles">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149401" class="link" href="/washington-redskins/need-know-first-look-redskins-vs-eagles">
      <span>First look at Redskins vs. Eagles</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-4">

      <div class="story__image">
              <a id="media-card-link-1149366" class="link" href="/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149366" class="link" href="/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson">
      <span>Presser wrap up: Cautious on Cravens, praise for Thompson</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-5">

      <div class="story__image">
              <a id="media-card-link-1149336" class="link" href="/washington-redskins/redskins-appreciated-chris-thompsons-production-work-ethic-awarding-extension">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149336" class="link" href="/washington-redskins/redskins-appreciated-chris-thompsons-production-work-ethic-awarding-extension">
      <span>Redskins appreciated Thompson&#039;s production, work ethic</span>
    </a>
  </h3>

  </div>
      </div>
</div>
          </div>
    <p>One of the thorny problems that the Redskins face in dealing with Su’a Cravens’ possible retirement and other, related issues is that the organization is in a massive time crunch. They need to prepare for a regular season game against the Eagles that is four days away. That is a task that consumes every waking minute of the coaches and most of the players’ time as well.</p>
<p><strong><em>RELATED: </em></strong><a href="http://www.csnmidatlantic.com/washington-redskins/need-know-first-look-redskins-vs-eagles"><strong><em>FIRST LOOK AT REDSKINS VS EAGLES</em></strong></a></p>
<p>But they don’t want to abandon Cravens at a time when he may be dealing with other personal issues in addition to wrestling with a retirement decision. The Redskins have found a possible solution to that problem.</p>
<p>“I think D-Hall [DeAngelo Hall] has kind of taken the lead on that,” said Jay Gruden when asked about the team’s communication with Cravens. “He’s done a great job of trying to communicate with him and help him.”</p>
<p>Hall has been with the Redskins since 2008, making him the longest-tenured Redskin. He currently is on the physically unable to perform list as he continues to rehab a torn ACL he suffered last year. While on the PUP list he attends meetings and works on conditioning and getting ready to play. But he is out for at least six weeks so he is one of the few people in the building who doesn't need to have the Eagles on his mind all the time.</p>
<p><strong><em>MORE REDSKINS: </em></strong><a href="http://www.csnmidatlantic.com/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson"><strong><em>GRUDEN PRESSER WRAP: PRAISE FOR THOMPSON</em></strong></a></p>
<p>Besides his availability to handle the Cravens situation, Hall is a good mix of mentor and colleague. Hall is 33, Cravens is 22 so the age gap is not too big to get in the way of communications but Hall’s 13 years in the NFL give him a gravitas that many other players can’t match. It seems likely that Cravens will listen to Hall.</p>
<p>That doesn’t mean that Hall will be able to solve Cravens’ issues or persuade him to want to do what it takes to play in the NFL. In any case, on the Redskins’ end,&nbsp;it’s a smart way to deal with the time crunch.</p>
<p><strong><em>Stay up to date on the Redskins. Rich Tandler covers the team 365 days a year. Like his Facebook page </em></strong><a href="http://www.facebook.com/TandlerCSN"><strong><em>Facebook.com/TandlerCSN</em></strong></a><strong><em> and follow him on Twitter </em></strong><a href="https://twitter.com/Rich_TandlerCSN"><strong><em>@Rich_TandlerCSN</em></strong></a><strong><em>.</em></strong></p>
 <iframe width="100%" height="300" style="background-color:transparent; display:block; padding: 0; max-width: 700px;" frameborder="0" allowtransparency="allowtransparency" scrolling="no" src="//embeds.audioboom.com/posts/6272809-episode-99-more-su-a-cravens-discussion-plus-chris-thompson-s-extension/embed/v4?eid=AQAAAPG7r1kpt18A" title="audioBoom player"></iframe>  
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/latest-headlines" rel="tag">Latest Headlines</a>, <a href="/tags/real-redskins" rel="tag">Real Redskins</a>, <a href="/tags/redskins-top-stories" rel="tag">Redskins Top Stories</a></span>
        <div class="comments-container">
              <div id="respond-1149651">
          <div id="1149651" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-1149651"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-1149651"></div>
    <div id="taboola-container-text-links-post-1149651"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-1149611" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <h3 class="article-trending-nav-prefix">Quick Links</h3><ul class="article-trending-nav"><li class="menu-5046 first"><a href="/washington-redskins/2017-nfl-power-rankings-who-got-better-after-draft">Power Rankings</a></li>
<li class="menu-4206"><a href="/video/general/redskins">Redskins Videos</a></li>
<li class="menu-4436"><a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a></li>
<li class="menu-4201 last"><a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-1149611"></div>
  <span id='chrome-data-post-1149611' class="hidden" data-chrome='{"league":"nfl","sport":"football","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Redskins Playbook: Kirk Cousins kills the Eagles; can he keep it up?    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-1149611"
         href="http://www.csnmidatlantic.com/video/blind-resume-how-does-kirk-cousins-compare"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/midatlantic_article/select/media/a9N06HSGsKPP?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnma/files/styles/article_hero_image/public/2017/08/29/blindresumecarrstaffordcousins_1920x1080_1035456579837.jpg?itok=5SimnTt8" width="656" height="369" alt="blindresumecarrstaffordcousins_1920x1080_1035456579837.jpg" title="Blind Resume: How does Kirk Cousins compare?" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Redskins Playbook: Kirk Cousins kills the Eagles; can he keep it up?    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/jp-finlay">JP Finlay</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnmidatlantic.com/washington-redskins/redskins-playbook-kirk-cousins-kills-eagles-can-he-keep-it"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">September 06, 2017 8:40 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-1149611" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-1149611" id="comments-link-1149611" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-1149611">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-headlines">
      <h3 class="media-card__title">
      Trending Now    </h3>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-1149646" class="link link_type-play link_type-block" href="/video/how-do-nationals-keep-competitive-mindset-17-game-lead">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=4Cmypolz&amp;timestamp=1504704485 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=l9WThANq&amp;timestamp=1504704485 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=4Cmypolz&amp;timestamp=1504704485 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=l9WThANq&amp;timestamp=1504704485 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=4Cmypolz&amp;timestamp=1504704485 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=l9WThANq&amp;timestamp=1504704485 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=4Cmypolz&amp;timestamp=1504704485 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=l9WThANq&amp;timestamp=1504704485 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-07-01.998z-1280x720.jpg?itok=4Cmypolz&amp;timestamp=1504704485" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">2:31</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149646" class="link" href="/video/how-do-nationals-keep-competitive-mindset-17-game-lead">
      <span>How do Nats keep a competitive mindset with 17 game lead?</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-2">

      <div class="story__image">
              <a id="media-card-link-1149641" class="link link_type-play link_type-block" href="/video/mike-rizzo-2017-nationals-most-balanced-team-theyve-ever-had">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=8G5fCP39&amp;timestamp=1504704302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=eOcXpr1b&amp;timestamp=1504704302 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=8G5fCP39&amp;timestamp=1504704302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=eOcXpr1b&amp;timestamp=1504704302 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=8G5fCP39&amp;timestamp=1504704302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=eOcXpr1b&amp;timestamp=1504704302 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=8G5fCP39&amp;timestamp=1504704302 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=eOcXpr1b&amp;timestamp=1504704302 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t13-05-43.367z-1280x720.jpg?itok=8G5fCP39&amp;timestamp=1504704302" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:14</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149641" class="link" href="/video/mike-rizzo-2017-nationals-most-balanced-team-theyve-ever-had">
      <span>Rizzo: 2017 Nationals &#039;most balanced team&#039; they&#039;ve ever had</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-3">

      <div class="story__image">
              <a id="media-card-link-1149551" class="link link_type-play link_type-block" href="/video/junkies-chris-thompsons-value-team-all-time-high-right-now">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=eJxyUosX&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=2td_JyNM&amp;timestamp=1504698231 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=eJxyUosX&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=2td_JyNM&amp;timestamp=1504698231 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=eJxyUosX&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=2td_JyNM&amp;timestamp=1504698231 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=eJxyUosX&amp;timestamp=1504698231 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=2td_JyNM&amp;timestamp=1504698231 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/2017-09-06t11-17-07.584z-1280x720.jpg?itok=eJxyUosX&amp;timestamp=1504698231" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">0:45</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149551" class="link" href="/video/junkies-chris-thompsons-value-team-all-time-high-right-now">
      <span>Junkies: Thompson&#039;s value to team at all time high right now</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-4">

      <div class="story__image">
              <a id="media-card-link-1149271" class="link link_type-play link_type-block" href="/video/jay-gruden-shows-compassion-towards-cravens-situation">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=fnhnbXS5&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=Potf3zYK&amp;timestamp=1504637881 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=fnhnbXS5&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=Potf3zYK&amp;timestamp=1504637881 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=fnhnbXS5&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=Potf3zYK&amp;timestamp=1504637881 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=fnhnbXS5&amp;timestamp=1504637881 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=Potf3zYK&amp;timestamp=1504637881 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/grudencravens_1920x1080_1039814723724.jpg?itok=fnhnbXS5&amp;timestamp=1504637881" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">5:18</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149271" class="link" href="/video/jay-gruden-shows-compassion-towards-cravens-situation">
      <span>Jay Gruden shows compassion towards the Cravens situation</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-5">

      <div class="story__image">
              <a id="media-card-link-1149031" class="link link_type-play link_type-block" href="/video/junkies-sua-cravens-just-doesnt-have-passion-play-football">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=Y1mflJrE&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=99EzVD8J&amp;timestamp=1504608653 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=Y1mflJrE&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=99EzVD8J&amp;timestamp=1504608653 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=Y1mflJrE&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=99EzVD8J&amp;timestamp=1504608653 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=Y1mflJrE&amp;timestamp=1504608653 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=99EzVD8J&amp;timestamp=1504608653 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/2017-09-05t10-27-47.999z-1280x720.jpg?itok=Y1mflJrE&amp;timestamp=1504608653" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">2:28</div>
                  </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149031" class="link" href="/video/junkies-sua-cravens-just-doesnt-have-passion-play-football">
      <span>Junkies: Cravens just doesn&#039;t have the passion for football</span>
    </a>
  </h3>

  </div>
      </div>
</div>
          </div>
    <p>Kirk Cousins plays his best facing the Eagles. In five career starts against Philadelphia, the Redskins quarterback has a 4-1 record. He's completed more than 63 percent of his passes for nearly 1,600 yards to go with 12 touchdowns against just three interceptions.&nbsp;</p>
<p>It's no coincidence&nbsp;the Redskins have not lost to the Eagles in their last five tries. The most important win of Cousins' career came Week 16 of 2015 in Philadelphia, where he played masterfully (365 yards, 4 TDs and no INTs) as the Redskins claimed the NFC East title.&nbsp;</p>
<p><strong><em>RELATED: <a href="http://www.csnmidatlantic.com/washington-redskins/need-know-first-look-redskins-vs-eagles">FIRST LOOK AT EAGLES VS. REDSKINS</a></em></strong></p>
<p>In two games last season, Cousins numbers slowed down a bit. He averaged about 245 yards per game against the Eagles, and in each contest threw two touchdowns against one interception. Still, Washington won both contests.</p>
<p>The question then isn't can Cousins beat the Eagles. It's how does Cousins keep the momentum against Philly going?</p>
<p>That will be the biggest question Sunday at FedEx Field. In three preseason games this season, Cousin didn't look particularly sharp.&nbsp;</p>
<p>Washington is working in new skill pieces all over their offense. Josh Doctson and Terrelle Pryor will replace DeSean Jackson and Pierre Garçon at the receiver spots. Cousins had a lot of time and experience working with Jackson and Garçon; the duo accounted for more than 40 percent of the QB's passing yards last season.&nbsp;</p>
<p>The Eagles can be beat. The Redskins have done it five straight times, but Washington has not won a season&nbsp;opener under head coach Jay Gruden.</p>
<p>Either the Redskins win streak over Philly snaps, or Gruden's winless opener streak breaks. Cousins will have a major say in that outcome.&nbsp;</p>
<p><em><a href="http://survivor.fantasy.nfl.com/group/38549">&lt;&lt;&lt;CLICK HERE TO JOIN #REDSKINSTALK PODCAST SURVIVOR POOL&gt;&gt;&gt;</a></em></p>
<p><em>Want more Redskins?&nbsp;<a href="https://www.facebook.com/JPFinlayCSN/">Click here to follow JP on Facebook</a>&nbsp;and check out&nbsp;<a href="http://www.twitter.com/jpfinlaycsn">@JPFinlayCSN</a>&nbsp;for live updates via Twitter!&nbsp;<a href="https://itunes.apple.com/us/podcast/redskins-talk/id1151988852?mt=2">Click here for the #RedskinsTalk on Apple Podcasts</a>,&nbsp;<a href="https://play.google.com/music/m/Iygppa4jqsc74swaa7q7vfdc3ym?t=Redskins_Talk">here for Google Play</a>&nbsp;or press play below. Don't forget to subscribe!</em></p>
<iframe width="100%" height="300" style="background-color:transparent; display:block; padding: 0; max-width: 700px;" frameborder="0" allowtransparency="allowtransparency" scrolling="no" src="//embeds.audioboom.com/posts/6272809-episode-99-more-su-a-cravens-discussion-plus-chris-thompson-s-extension/embed/v4?eid=AQAAAJrlr1kpt18A" title="audioBoom player"></iframe> 
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/kirk-cousins" rel="tag">Kirk Cousins</a>, <a href="/tags/latest-headlines" rel="tag">Latest Headlines</a>, <a href="/tags/must-see" rel="tag">Must See</a>, <a href="/tags/redskins-top-stories" rel="tag">Redskins Top Stories</a></span>
        <div class="comments-container">
              <div id="respond-1149611">
          <div id="1149611" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-1149611"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-1149611"></div>
    <div id="taboola-container-text-links-post-1149611"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-1149606" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <h3 class="article-trending-nav-prefix">Quick Links</h3><ul class="article-trending-nav"><li class="menu-5046 first"><a href="/washington-redskins/2017-nfl-power-rankings-who-got-better-after-draft">Power Rankings</a></li>
<li class="menu-4206"><a href="/video/general/redskins">Redskins Videos</a></li>
<li class="menu-4436"><a href="http://www.csnmidatlantic.com/author/jp-finlay">JP Finlay</a></li>
<li class="menu-4201 last"><a href="http://www.csnmidatlantic.com/realredskins">Real Redskins</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-1149606"></div>
  <span id='chrome-data-post-1149606' class="hidden" data-chrome='{"league":"nfl","sport":"football","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      After Chris Thompson deal, who else on the Redskins is in line for an extension?    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-1149606"
         href="http://www.csnmidatlantic.com/video/brian-mitchell-describes-many-skills-chris-thompson"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/midatlantic_article/select/media/SzXQDYKQaLN_?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/2017-09-06t02-15-25.979z-1280x720.jpg?itok=oUcwbO1g" width="656" height="369" alt="2017-09-06t02-15-25.979z-1280x720.jpg" title="Brian Mitchell describes the many skills of Chris Thompson" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      After Chris Thompson deal, who else on the Redskins is in line for an extension?    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/rich-tandler">Rich Tandler</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnmidatlantic.com/washington-redskins/after-chris-thompson-deal-who-else-redskins-line-extension"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">September 06, 2017 8:25 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-1149606" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-1149606" id="comments-link-1149606" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-1149606">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
              <div  class="media-card media-card_size-single media-card_type-headlines">
      <h3 class="media-card__title">
      Latest posts on Rich Tandler's Real Redskins    </h3>
    <div class="media-card__inner">
          <div  class="story story_count-1">

      <div class="story__image">
              <a id="media-card-link-1149651" class="link" href="/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/hall_usat.png?itok=zietMwmT&amp;timestamp=1504704272 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/hall_usat.png?itok=oHp5Oz7w&amp;timestamp=1504704272" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149651" class="link" href="/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens">
      <span>Hall is Redskins’ point man in communications with Cravens</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-2">

      <div class="story__image">
              <a id="media-card-link-1149606" class="link" href="/washington-redskins/after-chris-thompson-deal-who-else-redskins-line-extension">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/06/spencer_long_usat.png?itok=PID6D5xi&amp;timestamp=1504701004 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/06/spencer_long_usat.png?itok=HbF5Uwz5&amp;timestamp=1504701004" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149606" class="link" href="/washington-redskins/after-chris-thompson-deal-who-else-redskins-line-extension">
      <span>After Thompson, who else on the Redskins is in line for an extension?</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-3">

      <div class="story__image">
              <a id="media-card-link-1149401" class="link" href="/washington-redskins/need-know-first-look-redskins-vs-eagles">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=h1PYHWJh&amp;timestamp=1504655654 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/crowder_vs_eagles_usat.png?itok=1ViUq9GP&amp;timestamp=1504655654" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149401" class="link" href="/washington-redskins/need-know-first-look-redskins-vs-eagles">
      <span>First look at Redskins vs. Eagles</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-4">

      <div class="story__image">
              <a id="media-card-link-1149366" class="link" href="/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/redskinsvgb0374a.jpg?itok=3wg9woQN&amp;timestamp=1504648011 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/redskinsvgb0374a.jpg?itok=al7u3Azg&amp;timestamp=1504648011" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149366" class="link" href="/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson">
      <span>Presser wrap up: Cautious on Cravens, praise for Thompson</span>
    </a>
  </h3>

  </div>
          <div  class="story story_count-5">

      <div class="story__image">
              <a id="media-card-link-1149336" class="link" href="/washington-redskins/redskins-appreciated-chris-thompsons-production-work-ethic-awarding-extension">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571 1x, http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_2x_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=PTsKiT84&amp;timestamp=1504644571 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnmidatlantic.com/sites/csnma/files/styles/half_4__desktop_large_/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=qtGES61B&amp;timestamp=1504644571" alt="" title="" />
</picture>        </a>
          </div>
  
  <h3 class="story__title">
    <a id="media-card-link-1149336" class="link" href="/washington-redskins/redskins-appreciated-chris-thompsons-production-work-ethic-awarding-extension">
      <span>Redskins appreciated Thompson&#039;s production, work ethic</span>
    </a>
  </h3>

  </div>
      </div>
</div>
          </div>
    <p>The Redskins’ contract extension with Chris Thompson came together quickly. The running back said that talks gained momentum in just the last five days or so. The deal was finalized on Monday and he signed it when he went in to work at Redskins Park on Tuesday.</p>
<p>Thompson was one of 15 players currently on the 53-man roster who are set to be unrestricted free agents in 2018. Could an extension be in the works for any of the remaining 14?</p>
<p>They can’t talk to Kirk Cousins about a new deal now or any time before the Redskins’ season ends. That is a rule under the franchise tag. So that leaves 13 players with possibilities.</p>
<p>The prime candidates for extensions are the players the Redskins drafted in 2014. They now have completed three seasons of their rookie deals, making them eligible for new contracts. The Redskins already have done a deal with one such player, right tackle Morgan Moses. The other members of that draft class who are still on the roster are C Spencer Long, CB Bashaud Breeland, and WR Ryan Grant. In addition, OLB Trent Murphy, the team’s top draft pick in 2014, is on injured reserve.</p>
<p><strong><em>RELATED: </em></strong><a href="http://www.csnmidatlantic.com/washington-redskins/need-know-first-look-redskins-vs-eagles"><strong><em>FIRST LOOK AT REDSKINS VS EAGLES</em></strong></a></p>
<p>Of those players, the most likely to sign a new deal is Long. He is going into the year as the starting center. Long has started 25 games at center and guard in the last two years but this is the first time he is the Week 1 starter.</p>
<p>There is incentive on both sides to get a deal done. Long could take the risk that he may get injured this year and have problems finding work in 2018 off the table. The Redskins could lock in a solid player at a key position and guard against the recent explosion in prices paid for interior linemen. There are 13 guards and centers who currently have contracts with an average of over $9 million per year.</p>
<p>On the other hand, Long might look at those numbers and bet on himself. Even a very good season wouldn’t catapult Long into that $9 million-plus club. But if he has a good year he could make himself some more money.</p>
<p>A new deal for Breeland is very unlikely. The organization drafted cornerbacks in the third round in each of the past two years. That is a clear signal that they don’t plan to pay Breeland the $8 million-$10 million per year it likely will take to keep him in Washington.</p>
<p><strong><em>MORE REDSKINS: </em></strong><a href="http://www.csnmidatlantic.com/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson"><strong><em>GRUDEN PRESSER WRAP: PRAISE FOR THOMPSON</em></strong></a></p>
<p>Anything is possible with Grant, although I see him signing a one-year deal next fall. There is no reason to commit any significant money to him at this point.</p>
<p>The plan with Murphy probably will be to see how his rehab is going in the spring and base a short-term offer on that. There were no reports of extension talks going on before he got injured in the first preseason game. The injury certainly cost him millions of dollars, given that he was coming off a nine-sack season. As valued as pass rushing ability is in today’s NFL, even a good 2017 performance would have set him up for a deal in the $6 million per year range.</p>
<p>The possible free agents that fans would most like to see locked up for the long term are the two big-name free agents who got one-year deals last spring, WR Terrelle Pryor and ILB Zach Brown. However, the fans should not hold their collective breaths waiting for this to happen. Both signed one-year deals in hopes of having big years and getting lucrative, multiyear deals in the 2018 free agent market. Right now, the Redskins aren’t going to offer much more than the value that the track record of each player would command in the market. Both players want more and would rather go out on the field and try to earn it than settle for a market-value offer right now.</p>
<p>Maybe if one or both get off to good starts there could be extensions for one or both during the season. But the likely scenario is that Brown and Pryor play out the season on their current contracts and possibly start negotiations after that. It’s possible that if there is a good vibe in midseason something could get done. But that’s unlikely.</p>
<p><strong><em>Stay up to date on the Redskins. Rich Tandler covers the team 365 days a year. Like his Facebook page </em></strong><a href="http://www.facebook.com/TandlerCSN"><strong><em>Facebook.com/TandlerCSN</em></strong></a><strong><em> and follow him on Twitter </em></strong><a href="https://twitter.com/Rich_TandlerCSN"><strong><em>@Rich_TandlerCSN</em></strong></a><strong><em>.</em></strong></p>
 <iframe width="100%" height="300" style="background-color:transparent; display:block; padding: 0; max-width: 700px;" frameborder="0" allowtransparency="allowtransparency" scrolling="no" src="//embeds.audioboom.com/posts/6272809-episode-99-more-su-a-cravens-discussion-plus-chris-thompson-s-extension/embed/v4?eid=AQAAAPG7r1kpt18A" title="audioBoom player"></iframe>  
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/latest-headlines" rel="tag">Latest Headlines</a>, <a href="/tags/real-redskins" rel="tag">Real Redskins</a>, <a href="/tags/redskins-top-stories" rel="tag">Redskins Top Stories</a></span>
        <div class="comments-container">
              <div id="respond-1149606">
          <div id="1149606" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-1149606"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-1149606"></div>
    <div id="taboola-container-text-links-post-1149606"></div>
  </footer>
  <!-- .entry-footer -->
</article>
  </div>
  <div id="article-loadmore">
    <div class="footer_more-link">
      <a href="/articles/6/191/1" id="load_more_articles" class="use-ajax link link_type-block">Load more</a>    </div>
  </div>
</div>
  </div>
</div>
  </div>
                </div>
            </div>

                        <aside id="nbcsports-right-rail" class="sidebar sidebar_second">
                <div class="region region-right-rail">
    <div id="block-nbcs-article-nbcs-article-rail" class="block block-nbcs-article">

    
  <div class="content">
    <div id="story-explorer-wrapper">
 <aside id="story-explorer" class="styled-scrollbar">
    <div id="story-explorer-headlines">
      <div id="article-rail-ad"></div>
       <div id="article-rail-ad"></div>

<a href="/washington-redskins/deangelo-hall-redskins-point-man-communications-sua-cravens" class="story-explorer-item" id="headline-1149651">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/06/hall_usat.png?itok=W2EQn8HA" width="656" height="369" alt="hall_usat.png" title="DeAngelo Hall is Redskins’ point man in communications with Su&#039;a Cravens" /></span>
  <span class="item-headline">DeAngelo Hall is Redskins’ point man in communications with Su'a Cravens</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504704413"></span>
</a>

<a href="/washington-redskins/redskins-playbook-kirk-cousins-kills-eagles-can-he-keep-it" class="story-explorer-item" id="headline-1149611">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/06/usatsi_10250101_0.jpg?itok=AjkeOnOc" width="656" height="369" alt="usatsi_10250101.jpg" title="Redskins Playbook: Kirk Cousins kills the Eagles; can he keep it up?" /></span>
  <span class="item-headline">Redskins Playbook: Kirk Cousins kills the Eagles; can he keep it up?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504701771"></span>
</a>

<a href="/washington-redskins/after-chris-thompson-deal-who-else-redskins-line-extension" class="story-explorer-item" id="headline-1149606">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/06/spencer_long_usat.png?itok=56ka6KBA" width="656" height="369" alt="spencer_long_usat.png" title="After Chris Thompson deal, who else on the Redskins is in line for an extension?" /></span>
  <span class="item-headline">After Chris Thompson deal, who else on the Redskins is in line for an extension?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504701004"></span>
</a>

<a href="/washington-redskins/new-redskinstalk-podcast-talking-transition-sua-cravens-deshazor-everett" class="story-explorer-item" id="headline-1149596">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/06/screen_shot_2017-09-06_at_8.09.51_am.png?itok=hE-nL247" width="656" height="369" alt="screen_shot_2017-09-06_at_8.09.51_am.png" title="New #RedskinsTalk Podcast: Talking transition from Su&#039;a Cravens to Deshazor Everett" /></span>
  <span class="item-headline">New #RedskinsTalk Podcast: Talking transition from Su'a Cravens to Deshazor Everett</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504700001"></span>
</a>

<a href="/washington-redskins/need-know-first-look-redskins-vs-eagles" class="story-explorer-item" id="headline-1149401">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/crowder_vs_eagles_usat.png?itok=ipUyd8FL" width="656" height="369" alt="crowder_vs_eagles_usat.png" title="Need to Know: First look at Redskins vs. Eagles" /></span>
  <span class="item-headline">Need to Know: First look at Redskins vs. Eagles</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504655654"></span>
</a>

<a href="/washington-redskins/scot-mccloughan-comes-out-full-support-former-draft-pick-sua-cravens" class="story-explorer-item" id="headline-1149466">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/screen_shot_2017-09-05_at_11.25.18_pm_0.png?itok=xRsf68Rh" width="656" height="369" alt="screen_shot_2017-09-05_at_11.25.18_pm.png" title="Scot McCloughan comes out in full support of former draft pick Su&#039;a Cravens" /></span>
  <span class="item-headline">Scot McCloughan comes out in full support of former draft pick Su'a Cravens</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504668863"></span>
</a>

<a href="/washington-redskins/no-appeal-granted-ezekiel-elliott-cowboys-star-might-still-play-week-1-giants" class="story-explorer-item" id="headline-1149416">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/usatsi_10247378_141983962_lowres.jpg?itok=i7iyI-YK" width="656" height="369" alt="usatsi_10247378_141983962_lowres.jpg" title="No appeal granted for Ezekiel Elliott, but Cowboys star might still play Week 1 " /></span>
  <span class="item-headline">No appeal granted for Ezekiel Elliott, but Cowboys star might still play Week 1 </span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504658455"></span>
</a>

<a href="/washington-redskins/jay-gruden-presser-wrap-cautious-sua-cravens-praise-chris-thompson" class="story-explorer-item" id="headline-1149366">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/redskinsvgb0374a.jpg?itok=SNUdozd6" width="656" height="369" alt="redskinsvgb0374a.jpg" title="Jay Gruden presser wrap up: Cautious on Su&#039;a Cravens, praise for Chris Thompson" /></span>
  <span class="item-headline">Jay Gruden presser wrap up: Cautious on Su'a Cravens, praise for Chris Thompson</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504648011"></span>
</a>

<a href="/washington-redskins/redskins-appreciated-chris-thompsons-production-work-ethic-awarding-extension" class="story-explorer-item" id="headline-1149336">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/chris_thompson_vs_eagles_usat.png?itok=cNxr24z9" width="656" height="369" alt="chris_thompson_vs_eagles_usat.png" title="Redskins appreciated Chris Thompson&#039;s production, work ethic in awarding extension" /></span>
  <span class="item-headline">Redskins appreciated Chris Thompson's production, work ethic in awarding extension</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504644571"></span>
</a>

<a href="/washington-redskins/top-bottom-redskins-organization-deserves-credit-patience-compassion-cravens" class="story-explorer-item" id="headline-1149301">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/screen_shot_2017-09-05_at_4.35.06_pm.png?itok=P_2epOjt" width="656" height="369" alt="usatsi_10258049.jpg" title="From top to bottom, Redskins organization deserves credit for patience, compassion in Cravens situation" /></span>
  <span class="item-headline">From top to bottom, Redskins organization deserves credit for patience, compassion in Cravens situation</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504641474"></span>
</a>

<a href="/washington-redskins/theres-new-face-among-redskins-captains-2017-season" class="story-explorer-item" id="headline-1149326">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/usatsi_10258094_0.jpg?itok=ivhTq_nh" width="656" height="369" alt="usatsi_10258094.jpg" title="There&#039;s a new face among Redskins captains for 2017 season" /></span>
  <span class="item-headline">There's a new face among Redskins captains for 2017 season</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504643549"></span>
</a>

<a href="/washington-redskins/greg-manusky-apparently-hides-porta-potties-prank" class="story-explorer-item" id="headline-1149251">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/greg-manusky.png?itok=w-vAdQHD" width="656" height="369" alt="greg-manusky.png" title="Greg Manusky apparently hides in porta-potties as a prank" /></span>
  <span class="item-headline">Greg Manusky apparently hides in porta-potties as a prank</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504635512"></span>
</a>

<a href="/washington-redskins/redskins-release-week-1-depth-chart-rookie-jonathan-allen-makes-move" class="story-explorer-item" id="headline-1149131">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/tomsula-allen-redskins-csnma.jpg?itok=L7wo7ROj" width="656" height="369" alt="tomsula-allen-redskins-csnma.jpg" title="Redskins release Week 1 depth chart, rookie Jonathan Allen makes a move " /></span>
  <span class="item-headline">Redskins release Week 1 depth chart, rookie Jonathan Allen makes a move </span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504623137"></span>
</a>

<a href="/washington-redskins/redskins-reward-running-back-chris-thompson-contract-extension" class="story-explorer-item" id="headline-1149136">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/usatsi_9733863.jpg?itok=b8AJh24l" width="656" height="369" alt="usatsi_9733863.jpg" title="Redskins reward running back Chris Thompson with contract extension" /></span>
  <span class="item-headline">Redskins reward running back Chris Thompson with contract extension</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504624933"></span>
</a>

<a href="/washington-redskins/does-redskins-five-game-winning-streak-against-eagles-mean-anything" class="story-explorer-item" id="headline-1149121">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/kerrigan_vs_eagles_usat.png?itok=oyh0LSw2" width="656" height="369" alt="kerrigan_vs_eagles_usat.png" title="Does the Redskins&#039; five-game winning streak against the Eagles mean anything?" /></span>
  <span class="item-headline">Does the Redskins' five-game winning streak against the Eagles mean anything?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504622383"></span>
</a>

<a href="/washington-redskins/post-cuts-look-redskins-defensive-depth-chart" class="story-explorer-item" id="headline-1149071">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/linebackers_camp_usat.jpg?itok=sR6UZnc7" width="656" height="369" alt="linebackers_camp_usat.jpg" title="A post-cuts look at the Redskins defensive depth chart" /></span>
  <span class="item-headline">A post-cuts look at the Redskins defensive depth chart</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504614029"></span>
</a>

<a href="/washington-redskins/redskins-playbook-3-questions-jay-gruden-beyond-sua-cravens-situation" class="story-explorer-item" id="headline-1149056">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/grudendoctson1_1920x1080_1033923651722.jpg?itok=4ySkL-_Y" width="656" height="369" alt="grudendoctson1_1920x1080_1033923651722.jpg" title="Redskins Playbook: 3 questions for Jay Gruden beyond Su&#039;a Cravens situation" /></span>
  <span class="item-headline">Redskins Playbook: 3 questions for Jay Gruden beyond Su'a Cravens situation</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504613023"></span>
</a>

<a href="/washington-redskins/need-know-examining-redskins-roster-churn" class="story-explorer-item" id="headline-1148896">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/05/redskins_helmets_usat.png?itok=UnUxFksm" width="656" height="369" alt="redskins_helmets_usat.png" title="Need to Know: Examining the Redskins&#039; roster churn" /></span>
  <span class="item-headline">Need to Know: Examining the Redskins' roster churn</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504555126"></span>
</a>

<a href="/washington-redskins/sua-cravens-drops-some-hints-about-his-future-snapchat" class="story-explorer-item" id="headline-1148866">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/04/cravens.jpg?itok=7CXK7pV9" width="656" height="369" alt="cravens.jpg" title="Su&#039;a Cravens drops some hints about his future on Snapchat" /></span>
  <span class="item-headline">Su'a Cravens drops some hints about his future on Snapchat</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504551214"></span>
</a>

<a href="/washington-redskins/fantasy-football-2017-final-season-long-top-200-players-ranked" class="story-explorer-item" id="headline-1148841">
  <span class="item-thumbnail"><img src="/sites/csnma/files/styles/article_hero_image/public/2017/09/04/usatsi_9755994.jpg?itok=2_6EHHHS" width="656" height="369" alt="usatsi_9755994.jpg" title="Fantasy Football 2017 -- Final season-long Top 200 players ranked" /></span>
  <span class="item-headline">Fantasy Football 2017 -- Final season-long Top 200 players ranked</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1504545771"></span>
</a>
<div id="story-explorer-legal">
  </div>
    </div>
  </aside>
</div>
  </div>
</div>
  </div>
            </aside>
                      </div>

        </div>
        <!-- End main content -->

      </div>
      <!-- End content wrapper -->

      <!-- Start footer -->
      <footer id="nbcsports-footer">
          <div class="region region-footer">
    <div id="block-nbcs-footer-nbcs-footer" class="block block-nbcs-footer">

    
  <div class="content">
    <div id="footer-left">
  <div id="footer-logo"></div>
  <div id="footer-social-links">
    <span id="follow-us">FOLLOW US</span>
          <a href="http://facebook.com/CSNMA" class="genericon genericon-facebook">Facebook</a>          <a href="http://twitter.com/CSNMA" class="genericon genericon-twitter">Twitter</a>          <a href="http://instagram.com/CSNMA" class="genericon genericon-instagram">Instagram</a>      </div>
  <div id="copyright">©2017 Comcast SportsNet Mid-Atlantic, L.P.</div>
  <div id="footer-site-links">
          <a href="http://www.nbcuniversal.com/">A Division of NBC Universal</a>          <a href="http://www.nbcuniversal.com/privacy">Privacy Policy</a>          <a href="/terms_of_service">Terms of Service</a>          <a href="/contact">Contact Us</a>          <a href="http://www.csnmidatlantic.com/talent">Talent</a>          <a href="/advertise">Advertise</a>          <a href="http://www.csnmidatlantic.com/live-faq">Live FAQ</a>          <a href="http://www.nbcunicareers.com/search-results?search_type=criteria&amp;country=1&amp;state=23&amp;city=37&amp;keywords=">Jobs</a>          <a href="http://www.nbcunicareers.com/search-results?search_type=criteria&amp;country=1&amp;state=23&amp;city=37&amp;keywords=">Internships</a>          <a href="http://www.csnmidatlantic.com/press-releases/">Press Releases</a>          <a href="/ontv">TV Listings</a>          <a href="/rules">Sweepstakes</a>          <a href="/channel-finder">Channel Finder</a>          <a href="/alerts">Alerts</a>          <a href="http://email.comcastsportsnet.com/csn/prefw.do">Newsletters</a>          <a href="/page/closed-captioning">Closed Captioning</a>          <a href="http://corporate.comcast.com/news-information/nbcuniversal-transaction/independent-programming">Independent Programming Report</a>          <a href="http://info.evidon.com/pub_info/267?v=1">Ad Choices</a>      </div>
</div>
<div id="footer-right">
  <div id="footer-newsletter-link">
        <span id="newsletter-banner">GET NEWSLETTERS &amp; ALERTS</span>&#13;
    <a href="http://email.comcastsportsnet.com/csn/prefw.do" id="newsletter-link">SIGN UP</a>   </div>
</div>
  </div>
</div>
  </div>
      </footer>
      <!-- End footer -->

    </div><!-- end #outer -->
  </div><!-- end #wrapper -->
  <!-- SiteCatalyst code version: 1.7.0
Copyright 1996-2017 Adobe, Inc. -->
<script type="text/javascript" src="/sites/all/modules/custom/nbcs_sitecatalyst/js/nbcs_adobe.js?ov33bc"></script>
<script type="text/javascript"><!--

var nbcscontenthub="nbcs.contenthub";
s.contextData[nbcscontenthub]="News";
var nbcsteam="nbcs.team";
s.contextData[nbcsteam]="Washington Redskins";
var nbcsleague="nbcs.league";
s.contextData[nbcsleague]="NFL";
var nbcssport="nbcs.sport";
s.contextData[nbcssport]="Football";
var nbcsauthor="nbcs.author";
s.contextData[nbcsauthor]="Rich Tandler";
var nbcssubfeature="nbcs.subfeature";
s.contextData[nbcssubfeature]="Washington Redskins";
var nbcscontenttype="nbcs.contenttype";
s.contextData[nbcscontenttype]="Story";
var nbcscontentid="nbcs.contentid";
s.contextData[nbcscontentid]="1149651";
var nbcscontenttitle="nbcs.contenttitle";
s.contextData[nbcscontenttitle]="DeAngelo Hall is Redskins\u2019 point man in communications with Su\u0027a Cravens";
var nbcspagenumber="nbcs.pagenumber";
s.contextData[nbcspagenumber]=1;
var nbcsrelease_version="nbcs.release_version";
s.contextData[nbcsrelease_version]="2.1.2";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script>
<noscript><img src="http://examplecom.112.2O7.net/b/ss/examplecom/1/H.20.3--NS/0/3026390" height="1" width="1" alt=""></noscript>
<!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: 1.7.0 -->
<script type="text/javascript" src="//www.csnmidatlantic.com/sites/csnma/files/advagg_js/js__lOCAh6_G2-syfSonbl_eRlz9mAnNDG7xohglRBwEoSo__GS5ds9kzIoBH1l_hrriHCM_VLQv5drEonElm4bMePaA__k20LQm5nXwype9F3qZyqajN6AX8n1H10NwM1W-xPWbw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
typeof(mps)=='object' && typeof(mps.writeFooter)=='function' && mps.writeFooter();
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"cf07660617","applicationID":"15907363","transactionName":"ZQNbZ0cAX0UEABdcCVxJeFBBCF5YSg0MUQNtFlhUUD5HXwAU","queueTime":0,"applicationTime":579,"atts":"SURYEQ8aTEs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
